Security fix · CVE-2026-111768
MCP TypeScript SDK: One HTTP request within the default size limit could exhaust server memory during validation
Published Oct 20, 2026 · catalog updated Oct 20, 2026 · MCP TypeScript SDK: One
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Open the advisory
Exploitation likelihood is not on this record for CVE-2026-111768. A missing EPSS score is not a low risk. Compare MCP TypeScript SDK: One with the linked advisory before you change production.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (MCP TypeScript SDK: One).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- EPSS is missing. A missing score is not a low risk.
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- Not in the current FIRST EPSS dataset
- Remediation
- Version ranges on file
- Affected products
- npm @modelcontextprotocol/sdk · npm @modelcontextprotocol/server · package npm
### Summary In affected versions, servers put no limit on how many array elements and object keys they validated in one request. One HTTP request within the default 4 MiB size limit could exhaust the server's memory, and the process aborted with . No credentials are needed, unless you authenticate requests before they reach the SDK. ### Am I affected? Yes, if clients you do not fully trust can reach your server over HTTP. The risk is highest for tools whose input contains an array or a record. stdio-only servers are not affected. Affected versions: - 1.3.0 through 1.31.0 - 2.0.0 through 2.2.0 ### Fix Upgrade to: - 1.x: 1.32.0 or later - 2.x: 2.3.0 or later **Upgrading alone changes nothing.** The patched versions add an option, , that is off by default. Make both of these changes: 1. Set just above the largest input your tools need, for example . It counts array elements and object keys in a call's arguments. A call over the limit gets an result. 2. Lower the request size limit to what your tools need. The option covers tool arguments only, and the size limit covers everything else. Set on the transport or . If you parse the body yourself, for example with or Fastify, set that parser's limit. If you cannot upgrade yet, make the second change. needs 1.30.1 or 2.1.0. Below that, use a reverse proxy.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- npm @modelcontextprotocol/sdk>= 1.3.0, < 1.32.0
- npm @modelcontextprotocol/server>= 2.0.0, < 2.3.0
- package npmversion unspecified
How to fix CVE-2026-111768
Upgrade
CVE-2026-111768 lists a fix boundary at 1.32.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 1.32.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
Exploitation likelihood is not on this record for CVE-2026-111768. A missing EPSS score is not a low risk. Compare MCP TypeScript SDK: One with the linked advisory before you change production.
Which versions are affected?
Compare what you have installed with >= 1.3.0, < 1.32.0, >= 2.0.0, < 2.3.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-770: Allocation of Resources Without Limits or Throttling. EPSS is absent from the current FIRST dataset. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 20, 2026 · GitHub Advisory Database
Detected
### Summary In affected versions, servers put no limit on how many array elements and object keys they validated in one request. One HTTP request within the default 4 MiB size limit could exhaust the server's memory, and the process aborted with . No credentials are needed, unless you authenticate requests before they reach the SDK. ### Am I affected? Yes, if clients you do not fully trust can rea
Oct 20, 2026 · GitHub Advisory Database
Updated
### Summary In affected versions, servers put no limit on how many array elements and object keys they validated in one request. One HTTP request within the default 4 MiB size limit could exhaust the server's memory, and the process aborted with . No credentials are needed, unless you authenticate requests before they reach the SDK. ### Am I affected? Yes, if clients you do not fully trust can rea
Sources
- CVE.orgVulnerability recordCVE-2026-111768
Official CVE identifier
cve.org - GitHub Advisory DatabasePackage advisoryGHSA-46jr-4wx8-v453
MCP TypeScript SDK: One HTTP request within the default size limit could exhaust server memory during validation
github.com - Snyk Vulnerability DatabasePackage advisorySNYK-JS-MODELCONTEXTPROTOCOLSDK-21460687
Allocation of Resources Without Limits or Throttling
security.snyk.io - Snyk Vulnerability DatabasePackage advisorySNYK-JS-MODELCONTEXTPROTOCOLSERVER-21460686
Allocation of Resources Without Limits or Throttling
security.snyk.io
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Snyk Vulnerability DatabaseOct 25, 2026
- Snyk Vulnerability DatabaseOct 25, 2026
- CVE.orgOct 22, 2026
- GitHub Advisory DatabaseOct 21, 2026