Security incident · CVE-2026-113659
ApostropheCMS is an open-source Node.js content management system.
Published Oct 20, 2026 · catalog updated Oct 20, 2026 · ApostropheCMS is an open-source
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-113659. EPSS is 0.34%. Act only if a listed version of ApostropheCMS is an open-source is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (ApostropheCMS is an open-source).
- No version range is stored. A customer cannot check an installed version against this record.
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium6.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.34%
- Remediation
- Advisory link
- Affected products
- package npm
ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0, an unauthenticated attacker can send a crafted link whose query string is automatically parsed by apos.http.parseQuery when an authenticated victim loads a page with the admin bundle. The parser accepts the special __proto__, constructor, and prototype path keys, allowing browser prototype mutation that can reach an unsafe DOM sink and execute script in the victim's session; anonymous visitors do not load the affected admin context. This issue is fixed in version 4.33.0.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- package npmversion unspecified
How to fix CVE-2026-113659
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
No version range is stored, so an installed version cannot be checked on this page.
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-113659. EPSS is 0.34%. Act only if a listed version of ApostropheCMS is an open-source is installed.
Which versions are affected?
Affected version ranges are not on this record. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-1321: Improperly Controlled Modification of Object Prototype Attributes (Prototype Pollution); CWE-79: Cross-site Scripting (XSS). EPSS 0.34%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 20, 2026 · NIST NVD
Detected
ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0, an unauthenticated attacker can send a crafted link whose query string is automatically parsed by apos.http.parseQuery when an authenticated victim loads a page with the admin bundle. The parser accepts the special __proto__, constructor, and prototype path keys, allowing browser prototype mutation that can reach a
Oct 20, 2026 · NIST NVD
Updated
ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0, an unauthenticated attacker can send a crafted link whose query string is automatically parsed by apos.http.parseQuery when an authenticated victim loads a page with the admin bundle. The parser accepts the special __proto__, constructor, and prototype path keys, allowing browser prototype mutation that can reach a
Sources
- CVE.orgVulnerability recordCVE-2026-113659
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-113659
30-day exploitation probability 0.34%
first.org - NIST NVDVulnerability recordCVE-2026-113659
ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0, an unauthenticated attacker can send a crafted link whose query string is automatically parsed by apos.http.parseQuery when an authenticated victim loads a page with the admin bundle. The parser a
nvd.nist.gov - Snyk Vulnerability DatabasePackage advisorySNYK-JS-APOSTROPHE-21708415
Cross-site Scripting (XSS)
security.snyk.io
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Snyk Vulnerability DatabaseOct 27, 2026
- FIRST EPSSOct 23, 2026
- CVE.orgOct 21, 2026
- NIST NVDOct 21, 2026