Security fix · CVE-2026-113666
ApostropheCMS is an open-source Node.js content management system.
Published Oct 20, 2026 · catalog updated Oct 20, 2026 · ApostropheCMS is an open-source
Last checked Nov 7, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-113666. EPSS is 0.44%. Act only if a listed version of ApostropheCMS is an open-source is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (ApostropheCMS is an open-source).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High7.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.44%
- Remediation
- Advisory link
- Affected products
- npm @apostrophecms/db-connect · npm apostrophe · package npm
## Summary ships an in-memory MongoDB emulation used by its SQLite, PostgreSQL, and multipostgres adapters. Its helper walks an attacker-controlled dotted field path with no segment validation and calls on the resolved property. A low-privileged authenticated user (any role holding , which every editor and contributor has; reduced to any logged-in user when is enabled) can send a piece-type REST GET request whose query builder contains an exclusion key such as . On a SQLite or PostgreSQL adapter this key reaches , which resolves and deletes a shared runtime method. Because that method is shared across the whole Node process, the deletion breaks request handling for every tenant and user until the process is restarted, giving a single request a persistent denial of service. ## Root Cause The projection query builder laundens only projection values, never projection keys, so an arbitrary dotted key survives to the database layer. On the SQLite and PostgreSQL adapters an exclusion projection is applied in JavaScript by , which for each excluded field calls . splits the field on and walks the resulting segments with no guard: unlike its sibling , it does not even block a literal , and neither helper blocks or . Because the working object is a plain object produced by , its resolves to the global , so a path of reaches the shared and deletes a core, configurable method. The violated invariant is that untrusted input must never be able to traverse into and mutate shared prototype objects. ## Impact Prerequisites: an authenticated account holding (every editing role; any logged-in user when ), and a consumer configured to use a SQLite, PostgreSQL, or multipostgres adapter. The default adapter hands the projection to the real MongoDB driver and is not affected. With those conditions, a single crafted GET request deletes an attacker-chosen shared prototype method (for example , , or an member). The demonstrated capability is a persistent, process-wide denial of service: afte
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- npm @apostrophecms/db-connect0 → 1.1.0
- npm apostrophe0 → 4.33.0
- package npmversion unspecified
How to fix CVE-2026-113666
Upgrade
CVE-2026-113666 lists a fix boundary at 1.1.0. Compare the installed build with that boundary before you change production.
Version check
Fixed in 1.1.0 · 1 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-113666. EPSS is 0.44%. Act only if a listed version of ApostropheCMS is an open-source is installed.
Which versions are affected?
Compare what you have installed with 0 → 1.1.0, 0 → 4.33.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-1321: Improperly Controlled Modification of Object Prototype Attributes (Prototype Pollution); CWE-400: Uncontrolled Resource Consumption. EPSS 0.44%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 20, 2026 · GitHub Advisory Database
Fix available
@apostrophecms/db-connect fixed in 1.1.0; apostrophe fixed in 4.33.0
Oct 20, 2026 · NIST NVD
Detected
ApostropheCMS is an open-source Node.js content management system. Prior to 1.1.0 of db-connect and 4.33.0 of ApostropheCMS, an account with view-draft access can submit a projection exclusion path that traverses through a constructor prototype chain to a shared prototype member when a consumer uses a SQLite, PostgreSQL, or multipostgres adapter and has a matching document. Every editing role has
Oct 20, 2026 · GitHub Advisory Database
Fix available
@apostrophecms/db-connect fixed in 1.1.0
Oct 20, 2026 · GitHub Advisory Database
Fix available
apostrophe fixed in 4.33.0
Sources
- CVE.orgVulnerability recordCVE-2026-113666
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-113666
30-day exploitation probability 0.44%
first.org - GitHub Advisory DatabasePackage advisoryGHSA-j5rq-xfvr-p969
GitHub Advisory Database record mirrored by OSV.
github.com - NIST NVDVulnerability recordCVE-2026-113666
ApostropheCMS is an open-source Node.js content management system. Prior to 1.1.0 of db-connect and 4.33.0 of ApostropheCMS, an account with view-draft access can submit a projection exclusion path that traverses through a constructor prototype chain to a shared prototype member
nvd.nist.gov - OpenSSF OSV / OSV ScannerPackage advisoryGHSA-j5rq-xfvr-p969
ApostropheCMS: Authenticated projection-exclusion prototype-member deletion in @apostrophecms/db-connect causes process-wide denial of service
osv.dev - Snyk Vulnerability DatabasePackage advisorySNYK-JS-APOSTROPHE-21708417
Improper Validation of Specified Quantity in Input
security.snyk.io - Snyk Vulnerability DatabasePackage advisorySNYK-JS-APOSTROPHECMSDBCONNECT-21708418
Improper Validation of Specified Quantity in Input
security.snyk.io
References
Freshness
Last verified in this catalog Nov 7, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Snyk Vulnerability DatabaseOct 27, 2026
- Snyk Vulnerability DatabaseOct 27, 2026
- FIRST EPSSOct 23, 2026
- CVE.orgOct 21, 2026
- GitHub Advisory DatabaseOct 20, 2026
- OpenSSF OSV / OSV ScannerOct 20, 2026
- NIST NVDOct 20, 2026