Vulnerability · CVE-2026-114054
Use of Weak Hash
Published Oct 21, 2026 · catalog updated Nov 4, 2026 · Use of Weak Hash
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-114054. EPSS is 0.27%. Act only if a listed version of Use of Weak Hash is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Use of Weak Hash).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High7.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.27%
- Remediation
- Advisory link
- Affected products
- PyPI vllm · package pip
vLLM before 0.31.0 contains a cache aliasing vulnerability that allows authenticated attackers to collide shared cache keys by supplying caller-controlled values such as EXIF ImageID or cache_salt. Attackers can set a UUID EXIF ImageID to receive another request's cached processed media, or match cache_salt to a LoRA name to reuse first-block KV state.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- PyPI vllm0 → 0.31.0
- package pipversion unspecified
How to fix CVE-2026-114054
Upgrade
CVE-2026-114054 lists a fix boundary at 0.31.0. Compare the installed build with that boundary before you change production.
Version check
Fixed in 0.31.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-114054. EPSS is 0.27%. Act only if a listed version of Use of Weak Hash is installed.
Which versions are affected?
Compare what you have installed with 0 → 0.31.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-284: Improper Access Control. EPSS 0.27%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 21, 2026 · NIST NVD
Detected
vLLM before 0.31.0 contains a cache aliasing vulnerability that allows authenticated attackers to collide shared cache keys by supplying caller-controlled values such as EXIF ImageID or cache_salt. Attackers can set a UUID EXIF ImageID to receive another request's cached processed media, or match cache_salt to a LoRA name to reuse first-block KV state.
Oct 22, 2026 · NIST NVD
Updated
vLLM before 0.31.0 contains a cache aliasing vulnerability that allows authenticated attackers to collide shared cache keys by supplying caller-controlled values such as EXIF ImageID or cache_salt. Attackers can set a UUID EXIF ImageID to receive another request's cached processed media, or match cache_salt to a LoRA name to reuse first-block KV state.
Nov 4, 2026 · GitHub Advisory Database
Fix available
vllm fixed in 0.31.0
Nov 4, 2026 · GitHub Advisory Database
Fix available
vllm fixed in 0.31.0
Nov 4, 2026 · GitHub Advisory Database
Updated
vLLM before 0.31.0 contains a cache aliasing vulnerability that allows authenticated attackers to collide shared cache keys by supplying caller-controlled values such as EXIF ImageID or cache_salt. Attackers can set a UUID EXIF ImageID to receive another request's cached processed media, or match cache_salt to a LoRA name to reuse first-block KV state.
Sources
- CVE.orgVulnerability recordCVE-2026-114054
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-114054
30-day exploitation probability 0.27%
first.org - GitHub Advisory DatabasePackage advisoryGHSA-rh6f-3x46-j33q
GitHub Advisory Database record mirrored by OSV.
github.com - NIST NVDVulnerability recordCVE-2026-114054
vLLM before 0.31.0 contains a cache aliasing vulnerability that allows authenticated attackers to collide shared cache keys by supplying caller-controlled values such as EXIF ImageID or cache_salt. Attackers can set a UUID EXIF ImageID to receive another request's cached processe
nvd.nist.gov - OpenSSF OSV / OSV ScannerPackage advisoryPYSEC-2026-4362osv.dev
- PyPA Advisory DatabasePackage advisoryPYSEC-2026-4362
vLLM before 0.31.0 contains a cache aliasing vulnerability that allows authenticated attackers to collide shared cache keys by supplying caller-controlled values such as EXIF ImageID or cache_salt. Attackers can set a UUID EXIF ImageID to receive another request's cached processe
osv.dev - Snyk Vulnerability DatabasePackage advisorySNYK-PYTHON-VLLM-21347786
Use of Weak Hash
security.snyk.io
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- PyPA Advisory DatabaseNov 5, 2026
- GitHub Advisory DatabaseNov 5, 2026
- OpenSSF OSV / OSV ScannerNov 5, 2026
- Snyk Vulnerability DatabaseOct 23, 2026
- CVE.orgOct 23, 2026
- FIRST EPSSOct 23, 2026
- NIST NVDOct 22, 2026