Vulnerabilities

Vulnerability · CVE-2026-115353

Mistune before 3.3.0 contains a path traversal vulnerability in the RST include directive that allows attackers to read arbitrary files by supplying relative or absolute paths.

Published Oct 22, 2026 · catalog updated Oct 23, 2026 · Mistune before 3.3.0 contains

Last checked Nov 3, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-115353. EPSS is 0.39%. Act only if a listed version of Mistune before 3.3.0 contains is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Mistune before 3.3.0 contains).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Critical9.2
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.39%
Remediation
Advisory link
Affected products
Debian:12 mistune · Debian:13 mistune · Debian:14 mistune · vendor lepture mistune

Mistune before 3.3.0 contains a path traversal vulnerability in the RST include directive that allows attackers to read arbitrary files by supplying relative or absolute paths. Attackers can submit markdown containing include directives referencing ../ sequences or absolute paths to embed sensitive files like credentials or environment data in rendered HTML.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • Debian:12 mistune2.0.4-1, 2.0.4-2, 3.0.2-1
  • Debian:13 mistune3.1.3-1, 3.1.4-1, 3.3.4-1
  • Debian:14 mistune3.1.3-1, 3.1.4-1, 3.3.4-1
  • vendor lepture mistuneversion unspecified

How to fix CVE-2026-115353

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-115353. EPSS is 0.39%. Act only if a listed version of Mistune before 3.3.0 contains is installed.

Which versions are affected?

Compare what you have installed with 2.0.4-1, 2.0.4-2, 3.0.2-1, 3.1.3-1, 3.1.4-1, 3.3.4-1. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-22: Path Traversal. EPSS 0.39%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 23, 2026 · Trivy Vulnerability DB

    Detected

    Mistune before 3.3.0 contains a path traversal vulnerability in the RST include directive that allows attackers to read arbitrary files by supplying relative or absolute paths. Attackers can submit markdown containing include directives referencing ../ sequences or absolute paths to embed sensitive files like credentials or environment data in rendered HTML.

  2. Oct 23, 2026 · Trivy Vulnerability DB

    Updated

    Mistune before 3.3.0 contains a path traversal vulnerability in the RST include directive that allows attackers to read arbitrary files by supplying relative or absolute paths. Attackers can submit markdown containing include directives referencing ../ sequences or absolute paths to embed sensitive files like credentials or environment data in rendered HTML.

Sources

  • CVE.orgVulnerability recordCVE-2026-115353

    Mistune before 3.3.0 contains a path traversal vulnerability in the RST include directive that allows attackers to read arbitrary files by supplying relative or absolute paths. Attackers can submit markdown containing include directives referencing ../ sequences or absolute paths

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2026-115353

    30-day exploitation probability 0.39%

    first.org
  • Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-115353

    Mistune before 3.3.0 contains a path traversal vulnerability in the RST include directive that allows attackers to read arbitrary files by supplying relative or absolute paths. Attackers can submit markdown containing include directives referencing ../ sequences or absolute paths

    osv.dev

References

Freshness

Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 3, 2026
  • CVE.orgOct 23, 2026
  • Trivy Vulnerability DBOct 23, 2026