Vulnerabilities

Vulnerability · CVE-2026-115505

libsmb2 before 6.3 contains integer overflow vulnerabilities in the DCE/RPC NDR decoder in lib/dcerpc.c that allow heap out-of-bounds reads and writes.

Published Oct 22, 2026 · catalog updated Oct 23, 2026 · libsmb2 before 6.3 contains

Last checked Nov 3, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-115505. EPSS is 0.21%. Act only if a listed version of libsmb2 before 6.3 contains is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (libsmb2 before 6.3 contains).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
High7.2
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.21%
Remediation
Advisory link
Affected products
Debian:13 libsmb2 · Debian:14 libsmb2 · vendor sahlberg libsmb2

libsmb2 before 6.3 contains integer overflow vulnerabilities in the DCE/RPC NDR decoder in lib/dcerpc.c that allow heap out-of-bounds reads and writes. A malicious SMB server or machine-in-the-middle on unsigned connections can send crafted NetrShareEnum replies with wrapping actual_count or max_count values when clients call smb2_share_enum_async(), corrupting heap memory.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • Debian:13 libsmb26.2+dfsg-2, 6.2+dfsg-2+deb13u1, 6.2+dfsg-3
  • Debian:14 libsmb26.2+dfsg-2, 6.2+dfsg-3, 6.2+dfsg-4
  • vendor sahlberg libsmb2version unspecified

How to fix CVE-2026-115505

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-115505. EPSS is 0.21%. Act only if a listed version of libsmb2 before 6.3 contains is installed.

Which versions are affected?

Compare what you have installed with 6.2+dfsg-2, 6.2+dfsg-2+deb13u1, 6.2+dfsg-3, 6.2+dfsg-2, 6.2+dfsg-3, 6.2+dfsg-4. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-190: Integer Overflow. EPSS 0.21%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 23, 2026 · Trivy Vulnerability DB

    Detected

    libsmb2 before 6.3 contains integer overflow vulnerabilities in the DCE/RPC NDR decoder in lib/dcerpc.c that allow heap out-of-bounds reads and writes. A malicious SMB server or machine-in-the-middle on unsigned connections can send crafted NetrShareEnum replies with wrapping actual_count or max_count values when clients call smb2_share_enum_async(), corrupting heap memory.

  2. Oct 23, 2026 · Trivy Vulnerability DB

    Updated

    libsmb2 before 6.3 contains integer overflow vulnerabilities in the DCE/RPC NDR decoder in lib/dcerpc.c that allow heap out-of-bounds reads and writes. A malicious SMB server or machine-in-the-middle on unsigned connections can send crafted NetrShareEnum replies with wrapping actual_count or max_count values when clients call smb2_share_enum_async(), corrupting heap memory.

Sources

  • CVE.orgVulnerability recordCVE-2026-115505

    libsmb2 before 6.3 contains integer overflow vulnerabilities in the DCE/RPC NDR decoder in lib/dcerpc.c that allow heap out-of-bounds reads and writes. A malicious SMB server or machine-in-the-middle on unsigned connections can send crafted NetrShareEnum replies with wrapping act

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2026-115505

    30-day exploitation probability 0.21%

    first.org
  • Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-115505

    libsmb2 before 6.3 contains integer overflow vulnerabilities in the DCE/RPC NDR decoder in lib/dcerpc.c that allow heap out-of-bounds reads and writes. A malicious SMB server or machine-in-the-middle on unsigned connections can send crafted NetrShareEnum replies with wrapping act

    osv.dev

References

Freshness

Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 3, 2026
  • CVE.orgOct 23, 2026
  • Trivy Vulnerability DBOct 23, 2026