Vulnerabilities

Vulnerability · CVE-2026-115580

pypdf: Possible long runtimes for large xref table header limits

Published Oct 23, 2026 · catalog updated Oct 24, 2026 · Red Hat Red Hat Enterprise Linux

Last checked Nov 6, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-115580. EPSS is 0.41%. Act only if a listed version of Red Hat Red Hat Enterprise Linux is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium5.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.41%
Remediation
Version ranges on file
Affected products
Debian:12 pypdf · Debian:12 pypdf2 · Debian:13 pypdf · Debian:14 pypdf · package pip · pip pypdf

### Impact An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires opening a file with large/wrong upper limits in the xref table. ### Patches This has been fixed in [pypdf==6.21.2](https://github.com/py-pdf/pypdf/releases/tag/6.21.2). ### Workarounds If you cannot upgrade yet, consider applying the changes from PR [#4239](https://github.com/py-pdf/pypdf/pull/4239).

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • Debian:12 pypdf3.17.4-1, 3.4.1-1, 3.4.1-1+deb12u1
  • Debian:12 pypdf22.12.1-3, 2.12.1-3+deb12u1, 2.12.1-4
  • Debian:13 pypdf5.4.0-1, 6.19.0-1, 6.21.0-1
  • Debian:14 pypdf5.4.0-1, 6.19.0-1, 6.21.0-1
  • package pipversion unspecified
  • pip pypdf< 6.21.2
  • pypi pypdfversion unspecified

How to fix CVE-2026-115580

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-115580. EPSS is 0.41%. Act only if a listed version of Red Hat Red Hat Enterprise Linux is installed.

Which versions are affected?

Compare what you have installed with 3.17.4-1, 3.4.1-1, 3.4.1-1+deb12u1, 2.12.1-3, 2.12.1-3+deb12u1, 2.12.1-4, 5.4.0-1, 6.19.0-1, 6.21.0-1, < 6.21.2. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-606; CWE-834. EPSS 0.41%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 23, 2026 · Red Hat Security Data

    Detected

    pypdf: pypdf: Denial of Service via excessive cross-reference table entries

  2. Oct 23, 2026 · GitHub Advisory Database

    Updated

    ### Impact An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires opening a file with large/wrong upper limits in the xref table. ### Patches This has been fixed in [pypdf==6.21.2](https://github.com/py-pdf/pypdf/releases/tag/6.21.2). ### Workarounds If you cannot upgrade yet, consider applying the changes from PR [#4239](https://github.com/py-pdf/pypdf

  3. Oct 24, 2026 · Trivy Vulnerability DB

    Updated

    pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an attacker can craft a PDF with a standard cross-reference table whose declared entry count exceeds what the file can contain, causing excessive processing and long runtimes when the file is opened. This issue is fixed in version 6.21.2.

Sources

  • CVE.orgVulnerability recordCVE-2026-115580

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2026-115580

    30-day exploitation probability 0.41%

    first.org
  • GitHub Advisory DatabasePackage advisoryGHSA-gmh7-3g9r-mjh5

    pypdf: Possible long runtimes for large xref table header limits

    github.com
  • GitLab Advisory DatabasePackage advisoryCVE-2026-115580

    An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires opening a file with large/wrong upper limits in the xref table.

    advisories.gitlab.com
  • Red Hat Security DataVendor advisoryCVE-2026-115580

    pypdf: pypdf: Denial of Service via excessive cross-reference table entries

    access.redhat.com
  • Snyk Vulnerability DatabasePackage advisorySNYK-PYTHON-PYPDF-21663369

    Excessive Iteration

    security.snyk.io
  • Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-115580

    pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an attacker can craft a PDF with a standard cross-reference table whose declared entry count exceeds what the file can contain, causing excessive processing and long runtimes when the file is opened. This i

    osv.dev

References

Freshness

Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 6, 2026
  • GitLab Advisory DatabaseOct 27, 2026
  • Snyk Vulnerability DatabaseOct 26, 2026
  • CVE.orgOct 24, 2026
  • Trivy Vulnerability DBOct 24, 2026
  • GitHub Advisory DatabaseOct 24, 2026
  • Red Hat Security DataOct 24, 2026