Vulnerability · CVE-2026-115585
pypdf: Possible long runtimes for repeated malformed cross-reference entries (Follow-up)
Published Oct 23, 2026 · catalog updated Oct 24, 2026 · Red Hat Red Hat Enterprise Linux
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-115585. EPSS is 0.41%. Act only if a listed version of Red Hat Red Hat Enterprise Linux is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-121995 · High
- CVE-2026-121996 · High
- CVE-2026-121997 · High
- CVE-2026-121994 · High
- CVE-2026-111253 · Medium
- Severity
- Medium5.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.41%
- Remediation
- Version ranges on file
- Affected products
- Debian:12 pypdf · Debian:12 pypdf2 · Debian:13 pypdf · Debian:14 pypdf · package pip · pip pypdf
### Impact An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with repeated malformed cross-reference streams. ### Patches This has been fixed in [pypdf==6.21.2](https://github.com/py-pdf/pypdf/releases/tag/6.21.2). ### Workarounds If you cannot upgrade yet, consider applying the changes from PR [#4240](https://github.com/py-pdf/pypdf/pull/4240). ### Notes This is a follow-up to https://github.com/py-pdf/pypdf/security/advisories/GHSA-55h5-xmcq-c37v, which had the side-effect of still loading the whole stream again despite the cache being present.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:12 pypdf3.17.4-1, 3.4.1-1, 3.4.1-1+deb12u1
- Debian:12 pypdf22.12.1-3, 2.12.1-3+deb12u1, 2.12.1-4
- Debian:13 pypdf5.4.0-1, 6.19.0-1, 6.21.0-1
- Debian:14 pypdf5.4.0-1, 6.19.0-1, 6.21.0-1
- package pipversion unspecified
- pip pypdf< 6.21.2
- pypi pypdfversion unspecified
How to fix CVE-2026-115585
Upgrade
CVE-2026-115585 lists a fix boundary at 6.21.2. Compare the installed build with that boundary before you change production.
Version check
Affected < 6.21.2
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-115585. EPSS is 0.41%. Act only if a listed version of Red Hat Red Hat Enterprise Linux is installed.
Which versions are affected?
Compare what you have installed with 3.17.4-1, 3.4.1-1, 3.4.1-1+deb12u1, 2.12.1-3, 2.12.1-3+deb12u1, 2.12.1-4, 5.4.0-1, 6.19.0-1, 6.21.0-1, < 6.21.2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-400: Uncontrolled Resource Consumption; CWE-407; CWE-770: Allocation of Resources Without Limits or Throttling. EPSS 0.41%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 23, 2026 · Red Hat Security Data
Detected
pypdf: pypdf: Denial of Service via malformed cross-reference streams
Oct 23, 2026 · GitHub Advisory Database
Updated
### Impact An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with repeated malformed cross-reference streams. ### Patches This has been fixed in [pypdf==6.21.2](https://github.com/py-pdf/pypdf/releases/tag/6.21.2). ### Workarounds If you cannot upgrade yet, consider applying the changes from PR [#4240](https://github.com/py-
Oct 24, 2026 · Trivy Vulnerability DB
Updated
pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an incomplete remediation for repeated malformed cross-reference entries in GHSA-55h5-xmcq-c37v could still trigger a complete PDF stream reload during each recovery attempt even when a recovery cache was present, causing crafted cross-reference streams to produce long runtimes. This issue is fixed in version 6.21.2.
Sources
- CVE.orgVulnerability recordCVE-2026-115585
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-115585
30-day exploitation probability 0.41%
first.org - GitHub Advisory DatabasePackage advisoryGHSA-jr96-gvgh-j3r4
pypdf: Possible long runtimes for repeated malformed cross-reference entries (Follow-up)
github.com - GitLab Advisory DatabasePackage advisoryCVE-2026-115585
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with repeated malformed cross-reference streams.
advisories.gitlab.com - Red Hat Security DataVendor advisoryCVE-2026-115585
pypdf: pypdf: Denial of Service via malformed cross-reference streams
access.redhat.com - Snyk Vulnerability DatabasePackage advisorySNYK-PYTHON-PYPDF-21663371
Denial of Service (DoS)
security.snyk.io - Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-115585
pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an incomplete remediation for repeated malformed cross-reference entries in GHSA-55h5-xmcq-c37v could still trigger a complete PDF stream reload during each recovery attempt even when a recovery cache was p
osv.dev
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 6, 2026
- GitLab Advisory DatabaseOct 27, 2026
- Snyk Vulnerability DatabaseOct 26, 2026
- CVE.orgOct 24, 2026
- Trivy Vulnerability DBOct 24, 2026
- GitHub Advisory DatabaseOct 24, 2026
- Red Hat Security DataOct 24, 2026