Vulnerabilities

Vulnerability · CVE-2026-115751

mcp-from-openapi 2.2.0 before 2.9.0 SSRF blockedHosts Bypass via Trailing-Dot Hostname

Published Oct 23, 2026 · catalog updated Oct 23, 2026 · mcp-from-openapi 2.2.0 before 2.9.0

Last checked Nov 3, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-115751. EPSS is 0.25%. Act only if a listed version of mcp-from-openapi 2.2.0 before 2.9.0 is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (mcp-from-openapi 2.2.0 before 2.9.0).
  • No version range is stored. A customer cannot check an installed version against this record.
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium6.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.25%
Remediation
Advisory link
Affected products
vendor agentfront mcp-from-openapi

Agentfront mcp-from-openapi from 2.2.0 before 2.9.0 contains a server-side request forgery vulnerability that allows attackers to bypass the ssrf.blockedHosts denylist using trailing-dot hostnames. Attackers who control an OpenAPI spec URL or redirect target can append a root dot to a blocked hostname to fetch content from operator-blocked hosts.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor agentfront mcp-from-openapiversion unspecified

How to fix CVE-2026-115751

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-115751. EPSS is 0.25%. Act only if a listed version of mcp-from-openapi 2.2.0 before 2.9.0 is installed.

Which versions are affected?

Affected version ranges are not on this record. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-184. EPSS 0.25%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 23, 2026 · CIRCL Vulnerability Lookup

    Detected

    Agentfront mcp-from-openapi from 2.2.0 before 2.9.0 contains a server-side request forgery vulnerability that allows attackers to bypass the ssrf.blockedHosts denylist using trailing-dot hostnames. Attackers who control an OpenAPI spec URL or redirect target can append a root dot to a blocked hostname to fetch content from operator-blocked hosts.

Sources

  • CIRCL Vulnerability LookupVulnerability recordCVE-2026-115751

    Agentfront mcp-from-openapi from 2.2.0 before 2.9.0 contains a server-side request forgery vulnerability that allows attackers to bypass the ssrf.blockedHosts denylist using trailing-dot hostnames. Attackers who control an OpenAPI spec URL or redirect target can append a root dot

    vulnerability.circl.lu
  • CVE.orgVulnerability recordCVE-2026-115751

    CVE.org record is not available yet.

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2026-115751

    30-day exploitation probability 0.25%

    first.org

References

Freshness

Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 3, 2026
  • CVE.orgOct 23, 2026
  • CIRCL Vulnerability LookupOct 23, 2026