Vulnerability · CVE-2026-115892
Panic lowering a host-created component model stream into a guest that expects a different payload type
Published Oct 19, 2026 · catalog updated Oct 23, 2026 · RustSec Rust
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-115892. EPSS is 0.43%. Act only if a listed version of RustSec Rust is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-111959 · Medium
- RUSTSEC-2026-0430 · Unknown
- RUSTSEC-2026-0431 · Unknown
- RUSTSEC-2026-0432 · Unknown
- RUSTSEC-2026-0434 · Unknown
- Severity
- Medium5.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.43%
- Remediation
- Version ranges on file
- Affected products
- cargo wasmtime · crates.io wasmtime · package cargo · rust wasmtime
### Summary Wasmtime may panic when the host lowers a component model or into a guest, if the host created that stream or future with one payload type and the guest expects a different one. This can happen when an embedder creates a stream or future, passes it through a guest, receives it back under a type-erased type such as or , and then passes it to a guest function with a different payload type. GHSA-63h4-6cx9-pjfj is a related advisory also fixing issues within this area, and this advisory is being issued for portions of Wasmtime that were not fixed as part of that advisory. ### Impact This affects embedders that do all of the following: 1. Create streams or futures on the host with or 2. Pass them to guest code and receive them back as , , / , or a typed reader whose payload is one of these. 3. Pass them on to a guest function whose or payload type differs from the type the host created them with. A guest can cause the mismatch in step 3 when it controls the types of the functions it exports or of the values it returns. In that case a malicious guest can make the host panic, a denial of service. Embedders that only use statically typed / with concrete payload types throughout, or that never pass streams or futures they created through a guest and back, are not affected.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cargo wasmtimeversion unspecified
- crates.io wasmtime46.0.0 → 48.0.7
- crates.io wasmtime49.0.0 → 49.0.4
- package cargoversion unspecified
- rust wasmtime>= 46.0.0, < 48.0.7
- rust wasmtime>= 49.0.0, < 49.0.4
How to fix CVE-2026-115892
Upgrade
CVE-2026-115892 lists a fix boundary at 48.0.7. Compare the installed build with that boundary before you change production.
Version check
Affected < 48.0.7
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-115892. EPSS is 0.43%. Act only if a listed version of RustSec Rust is installed.
Which versions are affected?
Compare what you have installed with 46.0.0 → 48.0.7, 49.0.0 → 49.0.4, >= 46.0.0, < 48.0.7, >= 49.0.0, < 49.0.4. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-843: Access of Resource Using Incompatible Type (Type Confusion). EPSS 0.43%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 19, 2026 · GitHub Advisory Database
Detected
This is an entry in the RustSec database for the Wasmtime security advisory located at https://github.com/bytecodealliance/wasmtime/security/advisories/GHSA-9pvw-hwfg-92h5 For more information see the GitHub-hosted security advisory.
Oct 23, 2026 · GitHub Advisory Database
Fix available
wasmtime fixed in 48.0.7
Oct 23, 2026 · GitHub Advisory Database
Fix available
wasmtime fixed in 48.0.7
Oct 23, 2026 · GitHub Advisory Database
Fix available
wasmtime fixed in 48.0.7; wasmtime fixed in 49.0.4
Oct 23, 2026 · GitHub Advisory Database
Fix available
wasmtime fixed in 49.0.4
Oct 23, 2026 · GitHub Advisory Database
Updated
This is an entry in the RustSec database for the Wasmtime security advisory located at https://github.com/bytecodealliance/wasmtime/security/advisories/GHSA-9pvw-hwfg-92h5 For more information see the GitHub-hosted security advisory.
Sources
- CVE.orgVulnerability recordCVE-2026-115892
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-115892
30-day exploitation probability 0.43%
first.org - GitHub Advisory DatabasePackage advisoryGHSA-9pvw-hwfg-92h5
Wasmtime: Panic lowering a host-created component model stream into a guest that expects a different payload type
github.com - GitLab Advisory DatabasePackage advisoryCVE-2026-115892
Wasmtime may panic when the host lowers a component model stream or future into a guest, if the host created that stream or future with one payload type and the guest expects a different one. This can happen when an embedder creates a stream or future, passes it through a guest, receives it back under a type-erased type such as StreamAny or FutureAny, and then passes it to a guest …
advisories.gitlab.com - OpenSSF OSV / OSV ScannerPackage advisoryGHSA-9pvw-hwfg-92h5
Wasmtime: Panic lowering a host-created component model stream into a guest that expects a different payload type
osv.dev - OpenSSF OSV / OSV ScannerPackage advisoryRUSTSEC-2026-0378
Panic lowering a host-created component model stream into a guest that expects a different payload type
osv.dev - Red Hat Security DataVendor advisoryCVE-2026-115892
wasmtime: Wasmtime: Denial of Service via missing payload type validation in guest returns
access.redhat.com - RustSec Advisory DBVendor advisoryCVE-2026-115892
This is an entry in the RustSec database for the Wasmtime security advisory located at https://github.com/bytecodealliance/wasmtime/security/advisories/GHSA-9pvw-hwfg-92h5 For more information see the GitHub-hosted security advisory. (RUSTSEC-2026-0378)
crates.io - Snyk Vulnerability DatabasePackage advisorySNYK-RUST-WASMTIME-21708540
Access of Resource Using Incompatible Type ('Type Confusion')
security.snyk.io
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 6, 2026
- GitLab Advisory DatabaseOct 27, 2026
- Snyk Vulnerability DatabaseOct 27, 2026
- RustSec Advisory DBOct 26, 2026
- Red Hat Security DataOct 26, 2026
- CVE.orgOct 24, 2026
- GitHub Advisory DatabaseOct 24, 2026
- OpenSSF OSV / OSV ScannerOct 24, 2026
- OpenSSF OSV / OSV ScannerOct 24, 2026