Vulnerability · CVE-2026-116163
Parse Server before 8.6.102 and 9.0.0 before 9.10.5-alpha.2 contains an authentication bypass because the validateSetUp, validateLogin, and validateUpdate methods of custom adapter
Published Oct 25, 2026 · catalog updated Oct 25, 2026 · Parse Server before 8.6.102
Last checked Oct 27, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-116163. EPSS is 0.28%. Act only if a listed version of Parse Server before 8.6.102 is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Parse Server before 8.6.102).
- No version range is stored. A customer cannot check an installed version against this record.
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-110854 · High
- CVE-2026-109302 · Medium
- CVE-2026-105828 · Medium
- CVE-2026-43930 · Low
- CVE-2026-39381 · Medium
- Severity
- Critical9.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.28%
- Remediation
- Advisory link
- Affected products
- package npm · vendor parse-community · vendor parse-community parse-server
Parse Server before 8.6.102 and 9.0.0 before 9.10.5-alpha.2 contains an authentication bypass because the validateSetUp, validateLogin, and validateUpdate methods of custom adapters subclassing AuthAdapter are never called, and an inherited default that accepts any authData is used instead. Attackers can supply arbitrary authData to sign up, link identities, log in as existing users, or skip custom additional authentication factors.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- package npmversion unspecified
- vendor parse-communityversion unspecified
- vendor parse-community parse-serverversion unspecified
How to fix CVE-2026-116163
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
No version range is stored, so an installed version cannot be checked on this page.
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-116163. EPSS is 0.28%. Act only if a listed version of Parse Server before 8.6.102 is installed.
Which versions are affected?
Affected version ranges are not on this record. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-287: Improper Authentication. EPSS 0.28%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 25, 2026 · EUVD
Detected
Parse Server before 8.6.102 and 9.0.0 before 9.10.5-alpha.2 contains an authentication bypass because the validateSetUp, validateLogin, and validateUpdate methods of custom adapters subclassing AuthAdapter are never called, and an inherited default that accepts any authData is used instead. Attackers can supply arbitrary authData to sign up, link identities, log in as existing users, or skip custo
Oct 25, 2026 · CVE.org
Updated
Parse Server before 8.6.102 and 9.0.0 before 9.10.5-alpha.2 contains an authentication bypass because the validateSetUp, validateLogin, and validateUpdate methods of custom adapters subclassing AuthAdapter are never called, and an inherited default that accepts any authData is used instead. Attackers can supply arbitrary authData to sign up, link identities, log in as existing users, or skip custo
Sources
- CVE.orgVulnerability recordCVE-2026-116163
Parse Server before 8.6.102 and 9.0.0 before 9.10.5-alpha.2 contains an authentication bypass because the validateSetUp, validateLogin, and validateUpdate methods of custom adapters subclassing AuthAdapter are never called, and an inherited default that accepts any authData is us
cve.org - FIRST EPSSExploitation probabilityCVE-2026-116163
30-day exploitation probability 0.28%
first.org - EUVDVulnerability recordEUVD-2026-109424
Parse Server before 8.6.102 and 9.0.0 before 9.10.5-alpha.2 contains an authentication bypass because the validateSetUp, validateLogin, and validateUpdate methods of custom adapters subclassing AuthAdapter are never called, and an inherited default that accepts any authData is us
euvd.enisa.europa.eu - Snyk Vulnerability DatabasePackage advisorySNYK-JS-PARSESERVER-21708582
Improper Authentication
security.snyk.io
References
Freshness
Last verified in this catalog Oct 26, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Snyk Vulnerability DatabaseOct 27, 2026
- FIRST EPSSOct 26, 2026
- CVE.orgOct 25, 2026
- EUVDOct 25, 2026