Security fix · CVE-2026-116590
snappy-java: JVM crash from unchecked ranges in Snappy.arrayCopy and SnappyOutputStream.rawWrite
Published Oct 27, 2026 · catalog updated Oct 27, 2026 · snappy-java: JVM crash from
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-116590. EPSS is 0.41%. Act only if a listed version of snappy-java: JVM crash from is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (snappy-java: JVM crash from).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium5.9
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.41%
- Remediation
- Version ranges on file
- Affected products
- maven org.xerial.snappy · maven org.xerial.snappy:snappy-java
### Impact called a native without validating the ranges. A negative or oversized or offset read or wrote outside the arrays and crashed the JVM. and , and therefore the typed-array / methods, pass caller-supplied ranges to this method. ### Patches Fixed in 1.1.10.9 (#741). checks both ranges before copying. The stream / methods validate offsets and lengths, and reject typed-array ranges whose byte size overflows . ### Workarounds Validate offsets and lengths before calling these methods.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- maven org.xerial.snappyversion unspecified
- maven org.xerial.snappy:snappy-java<= 1.1.10.8
How to fix CVE-2026-116590
Upgrade
CVE-2026-116590 lists a fix boundary at 1.1.10.8. Compare the installed build with that boundary before you change production.
Version check
Affected <= 1.1.10.8
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-116590. EPSS is 0.41%. Act only if a listed version of snappy-java: JVM crash from is installed.
Which versions are affected?
Compare what you have installed with <= 1.1.10.8. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-129: Improper Validation of Array Index; CWE-787: Out-of-bounds Write. EPSS 0.41%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 27, 2026 · GitHub Advisory Database
Detected
### Impact called a native without validating the ranges. A negative or oversized or offset read or wrote outside the arrays and crashed the JVM. and , and therefore the typed-array / methods, pass caller-supplied ranges to this method. ### Patches Fixed in 1.1.10.9 (#741). checks both ranges before copying. The stream / methods validate offsets and lengths, and reject typed-array ranges whose byt
Sources
- CVE.orgVulnerability recordCVE-2026-116590
Official CVE identifier
cve.org - GitHub Advisory DatabasePackage advisoryGHSA-xqrx-qh46-34m7
snappy-java: JVM crash from unchecked ranges in Snappy.arrayCopy and SnappyOutputStream.rawWrite
github.com - GitLab Advisory DatabasePackage advisoryCVE-2026-116590
Snappy.arrayCopy(Object src, int offset, int byteLength, Object dest, int destOffset) called a native memcpy without validating the ranges. A negative or oversized byteLength or offset read or wrote outside the arrays and crashed the JVM. SnappyOutputStream.rawWrite and SnappyInputStream.rawRead, and therefore the typed-array write/read methods, pass caller-supplied ranges to this method.
advisories.gitlab.com
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- GitLab Advisory DatabaseOct 28, 2026
- CVE.orgOct 27, 2026
- GitHub Advisory DatabaseOct 27, 2026