Vulnerability · CVE-2026-116675
TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin serialization
Published Oct 27, 2026 · catalog updated Oct 27, 2026 · TinyMCE Cross-Site Scripting (XSS)
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-116675. EPSS is 0.35%. Act only if a listed version of TinyMCE Cross-Site Scripting (XSS) is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (TinyMCE Cross-Site Scripting (XSS)).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High—
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.35%
- Remediation
- Version ranges on file
- Affected products
- NuGet TinyMCE · Packagist tinymce/tinymce · composer tinymce · composer tinymce/tinymce · npm tinymce · nuget TinyMCE
### Impact Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled. ### Patches This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first. ### Workarounds No official workaround available. ### Fix To avoid this vulnerability: Upgrade to TinyMCE 8.9.3 or higher. Upgrade to TinyMCE 7.9.4 or higher. ### Acknowledgements Tiny thanks [Fariskhi Vidyan](https://github.com/farisv) and David Vieira Kurz (HiSolutions AG) for their help identifying this vulnerability.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- NuGet TinyMCE7.9.3 → 7.9.4
- NuGet TinyMCE8.5.1 → 8.9.3
- Packagist tinymce/tinymce7.9.3 → 7.9.4
- Packagist tinymce/tinymce8.5.1 → 8.9.3
- composer tinymceversion unspecified
- composer tinymce/tinymce= 7.9.3
- composer tinymce/tinymce>= 8.5.1, < 8.9.3
- npm tinymce7.9.3 → 7.9.4
- npm tinymce8.5.1 → 8.9.3
- npm tinymce= 7.9.3
- npm tinymce>= 8.5.1, < 8.9.3
- npm tinymce>=7.9.3 <7.9.4||>=8.5.1 <8.9.3
- nuget TinyMCE= 7.9.3
- nuget TinyMCE>= 8.5.1, < 8.9.3
- nuget tinymceversion unspecified
How to fix CVE-2026-116675
Upgrade
CVE-2026-116675 lists a fix boundary at 7.9.4. Compare the installed build with that boundary before you change production.
Version check
Affected < 8.9.3
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-116675. EPSS is 0.35%. Act only if a listed version of TinyMCE Cross-Site Scripting (XSS) is installed.
Which versions are affected?
Compare what you have installed with TinyMCE 7.9.3 → 7.9.4; TinyMCE 8.5.1 → 8.9.3; TinyMCE = 7.9.3; TinyMCE >= 8.5.1, < 8.9.3. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-79: Cross-site Scripting (XSS). EPSS 0.35%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 27, 2026 · GitHub Advisory Database
Detected
### Impact Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled. ### Patches This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any co
Oct 27, 2026 · GitHub Advisory Database
Fix available
tinymce fixed in 8.9.3; TinyMCE fixed in 8.9.3; tinymce/tinymce fixed in 8.9.3; tinymce fixed in 7.9.4
Oct 27, 2026 · GitHub Advisory Database
Fix available
tinymce fixed in 8.9.3
Oct 27, 2026 · GitHub Advisory Database
Fix available
TinyMCE fixed in 8.9.3
Oct 27, 2026 · GitHub Advisory Database
Fix available
tinymce/tinymce fixed in 8.9.3
Oct 27, 2026 · GitHub Advisory Database
Fix available
tinymce fixed in 7.9.4
Oct 27, 2026 · GitHub Advisory Database
Fix available
TinyMCE fixed in 7.9.4
Oct 27, 2026 · GitHub Advisory Database
Fix available
tinymce/tinymce fixed in 7.9.4
Oct 27, 2026 · GitHub Advisory Database
Updated
### Impact Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled. ### Patches This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any co
Sources
- CVE.orgVulnerability recordCVE-2026-116675
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-116675
30-day exploitation probability 0.35%
first.org - GitHub Advisory DatabasePackage advisoryGHSA-mf2p-h6hf-fcwm
GitHub Advisory Database record mirrored by OSV.
github.com - GitLab Advisory DatabasePackage advisoryCVE-2026-116675
Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled.
advisories.gitlab.com - GitLab Advisory DatabasePackage advisorynpm/tinymce/CVE-2026-116675.yml
Stored XSS vulnerability in the media plugin. Attackers can inject malicious + scripts via elements crafted through the data-mce-object attribute, which are created + and executed before sanitization. Impacts users of TinyMCE with the media plugin + enabled." +date: "2026-10-27" +pubdate: "2026-10-27" +affected_range: ">=7.9.3 =8.5.1 <8.9.3" +fixed_versions: +- "7.9.4" +- "8.9.3" +affected_version
gitlab.com - OpenSSF OSV / OSV ScannerPackage advisoryGHSA-mf2p-h6hf-fcwm
TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin serialization
osv.dev
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 6, 2026
- GitHub Advisory DatabaseNov 2, 2026
- OpenSSF OSV / OSV ScannerNov 2, 2026
- CVE.orgOct 28, 2026
- GitLab Advisory DatabaseOct 28, 2026
- GitLab Advisory DatabaseOct 28, 2026