Vulnerability · CVE-2026-116679
Neko: Authorization bypass in legacy WebRTC input handling
Published Oct 27, 2026 · catalog updated Oct 27, 2026 · Neko: Authorization bypass in
Last checked Nov 3, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-116679. EPSS is 0.31%. Act only if a listed version of Neko: Authorization bypass in is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Neko: Authorization bypass in).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium5.4
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.31%
- Remediation
- Version ranges on file
- Affected products
- Go github.com/m1k1o/neko/server · go github.com/m1k1o/neko/server · golang github.com
### Impact When legacy mode is enabled and is enabled, the legacy WebRTC data channel incorrectly authorizes input events due to a logic error in . As a result, an authenticated room member may be able to send mouse and keyboard input through the legacy WebRTC control channel even when controls are locked or the member would otherwise not be authorized through the modern control API. The issue affects only the legacy WebRTC input path. The modern HTTP/WebSocket control path correctly enforces authorization checks and is not affected. To exploit this issue, an attacker must: * Be authenticated as a room member. * Successfully establish a WebRTC connection. * Access a deployment using the legacy WebRTC input handler. No unauthenticated access or privilege escalation outside the application is possible. ### Patches The issue has been fixed in **[v3.1.5](https://github.com/m1k1o/neko/releases/tag/v3.1.5)** by correcting the authorization logic in the legacy WebRTC handler. Users should upgrade to **[v3.1.5](https://github.com/m1k1o/neko/releases/tag/v3.1.5)** or later. Fix: *[395ca1a](https://github.com/m1k1o/neko/commit/395ca1a6f62b7b0e270e654d366a2d57b8042efd)* ### Workarounds Users who cannot immediately upgrade can mitigate the issue by one of the following: * Disable legacy mode if it is not required. * Disable implicit hosting ( ). * Restrict access to trusted authenticated users. ### Credits Thanks to @KasperBuilds for responsibly disclosing this vulnerability and reaching out directly. This contribution helped strengthen the project, and the whole community benefits from it.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Go github.com/m1k1o/neko/server0.0.0-20250401220545-fe94c999c6af → 0.0.0-20260805142851-395ca1a6f62b
- go github.com/m1k1o/neko/server>= 0.0.0-20250401220545-fe94c999c6af, < 0.0.0-20260805142851-395ca1a6f62b
- golang github.comversion unspecified
How to fix CVE-2026-116679
Upgrade
CVE-2026-116679 lists a fix boundary at 0.0.0-20260805142851-395ca1a6f62b. Compare the installed build with that boundary before you change production.
Version check
Affected < 0.0.0-20260805142851-395ca1a6f62b
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-116679. EPSS is 0.31%. Act only if a listed version of Neko: Authorization bypass in is installed.
Which versions are affected?
Compare what you have installed with 0.0.0-20250401220545-fe94c999c6af → 0.0.0-20260805142851-395ca1a6f62b, >= 0.0.0-20250401220545-fe94c999c6af, < 0.0.0-20260805142851-395ca1a6f62b. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-863: Incorrect Authorization. EPSS 0.31%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 27, 2026 · GitHub Advisory Database
Detected
### Impact When legacy mode is enabled and is enabled, the legacy WebRTC data channel incorrectly authorizes input events due to a logic error in . As a result, an authenticated room member may be able to send mouse and keyboard input through the legacy WebRTC control channel even when controls are locked or the member would otherwise not be authorized through the modern control API. The issue aff
Oct 27, 2026 · GitHub Advisory Database
Fix available
github.com/m1k1o/neko/server fixed in 0.0.0-20260805142851-395ca1a6f62b
Oct 27, 2026 · GitHub Advisory Database
Fix available
github.com/m1k1o/neko/server fixed in 0.0.0-20260805142851-395ca1a6f62b
Oct 27, 2026 · GitHub Advisory Database
Updated
### Impact When legacy mode is enabled and is enabled, the legacy WebRTC data channel incorrectly authorizes input events due to a logic error in . As a result, an authenticated room member may be able to send mouse and keyboard input through the legacy WebRTC control channel even when controls are locked or the member would otherwise not be authorized through the modern control API. The issue aff
Sources
- CVE.orgVulnerability recordCVE-2026-116679
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-116679
30-day exploitation probability 0.31%
first.org - GitHub Advisory DatabasePackage advisoryGHSA-5cp7-fp4j-wwcv
GitHub Advisory Database record mirrored by OSV.
github.com - GitLab Advisory DatabasePackage advisoryCVE-2026-116679
When legacy mode is enabled and session.implicit_hosting is enabled, the legacy WebRTC data channel incorrectly authorizes input events due to a logic error in LegacyIsHost(). As a result, an authenticated room member may be able to send mouse and keyboard input through the legacy WebRTC control channel even when controls are locked or the member would otherwise not be authorized through the moder
advisories.gitlab.com - Go Vulnerability DatabasePackage advisoryGHSA-5cp7-fp4j-wwcv
Neko: Authorization bypass in legacy WebRTC input handling
osv.dev - OpenSSF OSV / OSV ScannerPackage advisoryGHSA-5cp7-fp4j-wwcv
Neko: Authorization bypass in legacy WebRTC input handling
osv.dev
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 3, 2026
- Go Vulnerability DatabaseOct 28, 2026
- GitHub Advisory DatabaseOct 28, 2026
- OpenSSF OSV / OSV ScannerOct 28, 2026
- CVE.orgOct 28, 2026
- GitLab Advisory DatabaseOct 28, 2026