Vulnerability · CVE-2026-118237
Out-of-bounds read vulnerability in GitHub Enterprise Server allowed disclosure of process memory in the Git service
Published Nov 3, 2026 · catalog updated Nov 3, 2026 · GitHub Enterprise Server
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-118237. EPSS is 0.27%. Act only if a listed version of GitHub Enterprise Server is installed.
Gaps on this record
- No version range is stored. A customer cannot check an installed version against this record.
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-110288 · Medium
- CVE-2026-104608 · High
- CVE-2026-3854 · High
- CVE-2025-13744 · High
- CVE-2025-11578 · High
- Severity
- Medium5.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.27%
- Remediation
- Not established
- Affected products
- vendor GitHub Enterprise Server
An out-of-bounds read vulnerability was identified in GitHub Enterprise Server in the Git service (babeld). When proving possession of a host key, babeld's SSH implementation sized the session identifier by the current digest length rather than its own. An attacker with an account and SSH access could re-key to an algorithm with a longer hash, causing adjacent process memory to be signed and returned to the client, where a limited amount of it may be recoverable. This vulnerability affected all releases prior to 3.23 and was fixed in versions 3.22.3, 3.21.8, 3.20.10, and 3.19.14. This vulnerability was reported via the GitHub Bug Bounty program.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor GitHub Enterprise Serverversion unspecified
How to fix CVE-2026-118237
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
No version range is stored, so an installed version cannot be checked on this page.
Advisory
Open the bsi record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-118237. EPSS is 0.27%. Act only if a listed version of GitHub Enterprise Server is installed.
Which versions are affected?
Affected version ranges are not on this record. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-125: Out-of-bounds Read. EPSS 0.27%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Nov 4, 2026 · BSI CERT-Bund
Detected
CVE-2026-118237 is listed by Microsoft GitHub Enterprise Server: Mehrere Schwachstellen.
Sources
- BSI CERT-BundGovernment advisoryCVE-2026-118237
Microsoft GitHub Enterprise Server: Mehrere Schwachstellen
wid.cert-bund.de - CVE.orgVulnerability recordCVE-2026-118237
An out-of-bounds read vulnerability was identified in GitHub Enterprise Server in the Git service (babeld). When proving possession of a host key, babeld's SSH implementation sized the session identifier by the current digest length rather than its own. An attacker with an accoun
cve.org
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- BSI CERT-BundNov 4, 2026