Vulnerabilities

Vulnerability · CVE-2026-119130

Wasmtime before 36.0.18, 37.0.0 before 48.0.6, and 49.0.0 before 49.0.3 HTTP Request Target Smuggling

Published Oct 29, 2026 · catalog updated Oct 30, 2026 · Wasmtime before 36.0.18, 37.0.0

Last checked Nov 5, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-119130. EPSS is 0.24%. Act only if a listed version of Wasmtime before 36.0.18, 37.0.0 is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Wasmtime before 36.0.18, 37.0.0).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Low2.1
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.24%
Remediation
Advisory link
Affected products
Debian:13 rust-wasmtime · Debian:14 rust-wasmtime · vendor bytecodealliance wasmtime

Wasmtime before 36.0.18, 37.0.0 before 48.0.6, and 49.0.0 before 49.0.3 does not verify that set-path-with-query values in wasmtime-wasi-http are paths, so absolute-form URLs are written verbatim as the HTTP/1.1 request target while the connection uses the allowed authority. A malicious guest can supply an absolute URL that a forward proxy or gateway at that authority honors, reaching hosts disallowed by embedder filtering policies.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • Debian:13 rust-wasmtime26.0.1+dfsg-10, 26.0.1+dfsg-3, 26.0.1+dfsg-4
  • Debian:14 rust-wasmtime26.0.1+dfsg-10, 26.0.1+dfsg-3, 26.0.1+dfsg-4
  • vendor bytecodealliance wasmtimeversion unspecified

How to fix CVE-2026-119130

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-119130. EPSS is 0.24%. Act only if a listed version of Wasmtime before 36.0.18, 37.0.0 is installed.

Which versions are affected?

Compare what you have installed with 26.0.1+dfsg-10, 26.0.1+dfsg-3, 26.0.1+dfsg-4. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-20: Improper Input Validation. EPSS 0.24%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 29, 2026 · OpenSSF OSV / OSV Scanner

    Detected

  2. Oct 30, 2026 · OpenSSF OSV / OSV Scanner

    Updated

    The description or metadata changed.

Sources

  • CVE.orgVulnerability recordCVE-2026-119130

    Wasmtime before 36.0.18, 37.0.0 before 48.0.6, and 49.0.0 before 49.0.3 does not verify that set-path-with-query values in wasmtime-wasi-http are paths, so absolute-form URLs are written verbatim as the HTTP/1.1 request target while the connection uses the allowed authority. A ma

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2026-119130

    30-day exploitation probability 0.24%

    first.org
  • OpenSSF OSV / OSV ScannerPackage advisoryDEBIAN-CVE-2026-119130
    osv.dev

References

Freshness

Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 5, 2026
  • CVE.orgOct 30, 2026
  • OpenSSF OSV / OSV ScannerOct 30, 2026