Vulnerabilities

Vulnerability · CVE-2026-119146

ProFTPD before 1.3.9e and 1.3.10rc5 contains a buffer overflow vulnerability in the mod_rewrite int:utf8trans RewriteMap that allows remote attackers to overwrite static buffers.

Published Oct 30, 2026 · catalog updated Nov 4, 2026 · ProFTPD before 1.3.9e and

Last checked Nov 6, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-119146. EPSS is 0.46%. Act only if a listed version of ProFTPD before 1.3.9e and is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (ProFTPD before 1.3.9e and).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
Medium5.6
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.46%
Remediation
Advisory link
Affected products
Alpine:v3.23 proftpd · Alpine:v3.24 proftpd · Debian:12 proftpd-dfsg · Debian:13 proftpd-dfsg · Debian:14 proftpd-dfsg

ProFTPD before 1.3.9e and 1.3.10rc5 contains a buffer overflow vulnerability in the mod_rewrite int:utf8trans RewriteMap that allows remote attackers to overwrite static buffers. Attackers can send FTP command arguments longer than 1024 bytes, without authentication if pre-login commands are rewritten, to corrupt session memory and crash the session.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • Alpine:v3.23 proftpd0 → 1.3.9e-r0
  • Alpine:v3.24 proftpd0 → 1.3.9e-r0
  • Debian:12 proftpd-dfsg1.3.8+dfsg-4, 1.3.8+dfsg-4+deb12u1, 1.3.8+dfsg-4+deb12u2
  • Debian:13 proftpd-dfsg1.3.8.c+dfsg-4, 1.3.8.c+dfsg-4+deb13u1, 1.3.8.c+dfsg-4+deb13u2
  • Debian:14 proftpd-dfsg1.3.8.c+dfsg-4, 1.3.9a~dfsg-1, 1.3.9b~dfsg-1

How to fix CVE-2026-119146

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-119146. EPSS is 0.46%. Act only if a listed version of ProFTPD before 1.3.9e and is installed.

Which versions are affected?

Compare what you have installed with 0 → 1.3.9e-r0, 1.3.8+dfsg-4, 1.3.8+dfsg-4+deb12u1, 1.3.8+dfsg-4+deb12u2, 1.3.8.c+dfsg-4, 1.3.8.c+dfsg-4+deb13u1, 1.3.8.c+dfsg-4+deb13u2, 1.3.8.c+dfsg-4, 1.3.9a~dfsg-1, 1.3.9b~dfsg-1. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.46%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 30, 2026 · Trivy Vulnerability DB

    Detected

    ProFTPD before 1.3.9e and 1.3.10rc5 contains a buffer overflow vulnerability in the mod_rewrite int:utf8trans RewriteMap that allows remote attackers to overwrite static buffers. Attackers can send FTP command arguments longer than 1024 bytes, without authentication if pre-login commands are rewritten, to corrupt session memory and crash the session.

  2. Oct 31, 2026 · Trivy Vulnerability DB

    Updated

    ProFTPD before 1.3.9e and 1.3.10rc5 contains a buffer overflow vulnerability in the mod_rewrite int:utf8trans RewriteMap that allows remote attackers to overwrite static buffers. Attackers can send FTP command arguments longer than 1024 bytes, without authentication if pre-login commands are rewritten, to corrupt session memory and crash the session.

  3. Nov 4, 2026 · OpenSSF OSV / OSV Scanner

    Fix available

    proftpd fixed in 1.3.9e-r0; proftpd fixed in 1.3.9e-r0

  4. Nov 4, 2026 · OpenSSF OSV / OSV Scanner

    Fix available

    proftpd fixed in 1.3.9e-r0

  5. Nov 4, 2026 · OpenSSF OSV / OSV Scanner

    Updated

    ProFTPD before 1.3.9e and 1.3.10rc5 contains a buffer overflow vulnerability in the mod_rewrite int:utf8trans RewriteMap that allows remote attackers to overwrite static buffers. Attackers can send FTP command arguments longer than 1024 bytes, without authentication if pre-login commands are rewritten, to corrupt session memory and crash the session.

Sources

  • CVE.orgVulnerability recordCVE-2026-119146

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2026-119146

    30-day exploitation probability 0.46%

    first.org
  • OpenSSF OSV / OSV ScannerPackage advisoryALPINE-CVE-2026-119146
    osv.dev
  • Trivy Vulnerability DBPackage advisoryALPINE-CVE-2026-119146

    ProFTPD before 1.3.9e and 1.3.10rc5 contains a buffer overflow vulnerability in the mod_rewrite int:utf8trans RewriteMap that allows remote attackers to overwrite static buffers. Attackers can send FTP command arguments longer than 1024 bytes, without authentication if pre-login

    osv.dev
  • Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-119146

    ProFTPD before 1.3.9e and 1.3.10rc5 contains a buffer overflow vulnerability in the mod_rewrite int:utf8trans RewriteMap that allows remote attackers to overwrite static buffers. Attackers can send FTP command arguments longer than 1024 bytes, without authentication if pre-login

    osv.dev

References

Freshness

Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 6, 2026
  • Trivy Vulnerability DBNov 4, 2026
  • OpenSSF OSV / OSV ScannerNov 4, 2026
  • CVE.orgOct 31, 2026
  • Trivy Vulnerability DBOct 31, 2026