Vulnerabilities

Vulnerability · CVE-2026-119376

SQLite before 3.54.0 contains a stack exhaustion vulnerability that allows attackers to bypass the SQLITE_LIMIT_EXPR_DEPTH limit by chaining COLLATE postfix operators.

Published Nov 3, 2026 · catalog updated Nov 4, 2026 · SQLite before 3.54.0 contains

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-119376. EPSS is 0.18%. Act only if a listed version of SQLite before 3.54.0 contains is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (SQLite before 3.54.0 contains).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
Medium5.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.18%
Remediation
Advisory link
Affected products
Ubuntu:14.04:LTS sqlite · Ubuntu:16.04:LTS sqlite · Ubuntu:18.04:LTS sqlite · Ubuntu:20.04:LTS sqlite · Ubuntu:22.04:LTS sqlite · Ubuntu:22.04:LTS sqlite3

SQLite before 3.54.0 contains a stack exhaustion vulnerability that allows attackers to bypass the SQLITE_LIMIT_EXPR_DEPTH limit by chaining COLLATE postfix operators. Attackers can supply roughly 175,000 chained COLLATE operators in SQL or an untrusted database view to trigger unbounded recursion in sqlite3WalkExprNN() and crash the process.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • Ubuntu:14.04:LTS sqlite2.8.17-8fakesync1, 2.8.17-9fakesync1, 2.8.17-10ubuntu2
  • Ubuntu:16.04:LTS sqlite2.8.17-12fakesync1
  • Ubuntu:18.04:LTS sqlite2.8.17-14fakesync1
  • Ubuntu:20.04:LTS sqlite2.8.17-15fakesync1build1
  • Ubuntu:22.04:LTS sqlite2.8.17-15fakesync1build1
  • Ubuntu:22.04:LTS sqlite33.35.5-1, 3.36.0-2, 3.37.2-2
  • Ubuntu:24.04:LTS sqlite33.42.0-1, 3.44.0-1, 3.44.2-1
  • Ubuntu:26.10 sqlite33.46.1-9, 3.53.4-2
  • Ubuntu:Pro:14.04:LTS sqlite33.7.17-1ubuntu1, 3.8.0.2-1ubuntu1, 3.8.1-1ubuntu1
  • Ubuntu:Pro:16.04:LTS sqlite33.8.11.1-1, 3.9.1-2, 3.9.2-1
  • Ubuntu:Pro:18.04:LTS sqlite33.19.3-3, 3.20.1-2, 3.21.0-1
  • Ubuntu:Pro:20.04:LTS sqlite33.29.0-2, 3.30.1-1, 3.30.1-1ubuntu1

How to fix CVE-2026-119376

  • No stored fix

    No vendor fix text is stored. Use the linked advisory before you change production.

  • Version check

    Seen in 2.8.17-8fakesync1 · 9 other packages on the advisory

  • Advisory

    Open the cve_org record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-119376. EPSS is 0.18%. Act only if a listed version of SQLite before 3.54.0 contains is installed.

Which versions are affected?

Compare what you have installed with 2.8.17-8fakesync1, 2.8.17-9fakesync1, 2.8.17-10ubuntu2, 2.8.17-12fakesync1, 2.8.17-14fakesync1, 2.8.17-15fakesync1build1, 3.35.5-1, 3.36.0-2, 3.37.2-2, 3.42.0-1, 3.44.0-1, 3.44.2-1. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.18%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 3, 2026 · OpenSSF OSV / OSV Scanner

    Detected

    SQLite before 3.54.0 contains a stack exhaustion vulnerability that allows attackers to bypass the SQLITE_LIMIT_EXPR_DEPTH limit by chaining COLLATE postfix operators. Attackers can supply roughly 175,000 chained COLLATE operators in SQL or an untrusted database view to trigger unbounded recursion in sqlite3WalkExprNN() and crash the process.

  2. Nov 4, 2026 · OpenSSF OSV / OSV Scanner

    Updated

    SQLite before 3.54.0 contains a stack exhaustion vulnerability that allows attackers to bypass the SQLITE_LIMIT_EXPR_DEPTH limit by chaining COLLATE postfix operators. Attackers can supply roughly 175,000 chained COLLATE operators in SQL or an untrusted database view to trigger unbounded recursion in sqlite3WalkExprNN() and crash the process.

Sources

References

Freshness

Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgNov 4, 2026
  • OpenSSF OSV / OSV ScannerNov 4, 2026