Vulnerability · CVE-2026-119760
sniproxy through 0.7.0 contains a NULL pointer dereference vulnerability in resolv_cancel() that allows remote unauthenticated attackers to crash the daemon by sending overlong hos
Published Oct 30, 2026 · catalog updated Nov 5, 2026 · sniproxy through 0.7.0 contains
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-119760. EPSS is 0.48%. Act only if a listed version of sniproxy through 0.7.0 contains is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (sniproxy through 0.7.0 contains).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.48%
- Remediation
- Advisory link
- Affected products
- Debian:12 sniproxy · Debian:13 sniproxy · Debian:14 sniproxy
sniproxy through 0.7.0 contains a NULL pointer dereference vulnerability in resolv_cancel() that allows remote unauthenticated attackers to crash the daemon by sending overlong hostnames. Attackers can send a 254 or 255 character TLS SNI name or HTTP Host header matching a wildcard backend, then close the connection to terminate the proxy.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:12 sniproxy0.6.0-2.1, 0.6.1+git20240321-0.1, 0.6.1+git20240321-0.1~bpo12+1
- Debian:13 sniproxy0.6.1+git20240321-0.2, 0.7.0-1, 0.7.0-2
- Debian:14 sniproxy0 → 0.7.0-2
- Debian:14 sniproxy0.6.1+git20240321-0.2, 0.7.0-1, 0.7.0-2
How to fix CVE-2026-119760
Upgrade
CVE-2026-119760 lists a fix boundary at 0.7.0-2. Compare the installed build with that boundary before you change production.
Version check
Fixed in 0.7.0-2 · 9 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-119760. EPSS is 0.48%. Act only if a listed version of sniproxy through 0.7.0 contains is installed.
Which versions are affected?
Compare what you have installed with 0.6.0-2.1, 0.6.1+git20240321-0.1, 0.6.1+git20240321-0.1~bpo12+1, 0.6.1+git20240321-0.2, 0.7.0-1, 0.7.0-2, 0 → 0.7.0-2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.48%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Oct 30, 2026 · Trivy Vulnerability DB
Detected
sniproxy through 0.7.0 contains a NULL pointer dereference vulnerability in resolv_cancel() that allows remote unauthenticated attackers to crash the daemon by sending overlong hostnames. Attackers can send a 254 or 255 character TLS SNI name or HTTP Host header matching a wildcard backend, then close the connection to terminate the proxy.
Oct 31, 2026 · Trivy Vulnerability DB
Updated
sniproxy through 0.7.0 contains a NULL pointer dereference vulnerability in resolv_cancel() that allows remote unauthenticated attackers to crash the daemon by sending overlong hostnames. Attackers can send a 254 or 255 character TLS SNI name or HTTP Host header matching a wildcard backend, then close the connection to terminate the proxy.
Nov 5, 2026 · Trivy Vulnerability DB
Fix available
sniproxy fixed in 0.7.0-2
Nov 5, 2026 · Trivy Vulnerability DB
Fix available
sniproxy fixed in 0.7.0-2
Nov 5, 2026 · Trivy Vulnerability DB
Updated
sniproxy through 0.7.0 contains a NULL pointer dereference vulnerability in resolv_cancel() that allows remote unauthenticated attackers to crash the daemon by sending overlong hostnames. Attackers can send a 254 or 255 character TLS SNI name or HTTP Host header matching a wildcard backend, then close the connection to terminate the proxy.
Sources
- CVE.orgVulnerability recordCVE-2026-119760
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-119760
30-day exploitation probability 0.48%
first.org - Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-119760
sniproxy through 0.7.0 contains a NULL pointer dereference vulnerability in resolv_cancel() that allows remote unauthenticated attackers to crash the daemon by sending overlong hostnames. Attackers can send a 254 or 255 character TLS SNI name or HTTP Host header matching a wildca
osv.dev
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 6, 2026
- Trivy Vulnerability DBNov 5, 2026
- CVE.orgOct 31, 2026