Security fix · CVE-2026-119978
Flowise NodeVM sandbox escape via puppeteer allowlist - authenticated RCE and arbitrary file read via Chromium
Published Oct 7, 2026 · catalog updated Oct 31, 2026 · Flowise NodeVM sandbox escape
Last checked Nov 3, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-119978. EPSS is 0.34%. Act only if a listed version of Flowise NodeVM sandbox escape is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Flowise NodeVM sandbox escape).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Critical—
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.34%
- Remediation
- Advisory link
- Affected products
- npm flowise · npm flowise-components
Flowise (packages flowise and flowise-components) in versions <= 3.1.2 contain a sandbox escape in the JavaScript sandbox. An authenticated user with access to the endpoint can escape the sandbox by supplying attacker-controlled executablePath and args parameters to puppeteer.launch(), which internally invokes child_process.spawn() outside the sandbox boundary. This allows execution of arbitrary OS commands as the Flowise process user (root in the official Docker image) and arbitrary host file disclosure via Chromium's URL handling. In versions 3.0.8–3.1.2 exploitation requires ; earlier versions are exploitable by default. Fixed in 3.1.3.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- npm flowise0 → 3.1.3
- npm flowise-components0 → 3.1.3
How to fix CVE-2026-119978
Upgrade
CVE-2026-119978 lists a fix boundary at 3.1.3. Compare the installed build with that boundary before you change production.
Version check
Fixed in 3.1.3 · 1 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-119978. EPSS is 0.34%. Act only if a listed version of Flowise NodeVM sandbox escape is installed.
Which versions are affected?
Compare what you have installed with 0 → 3.1.3. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.34%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 7, 2026 · GitHub Advisory Database
Detected
Flowise (packages flowise and flowise-components) in versions <= 3.1.2 contain a sandbox escape in the JavaScript sandbox. An authenticated user with access to the endpoint can escape the sandbox by supplying attacker-controlled executablePath and args parameters to puppeteer.launch(), which internally invokes child_process.spawn() outside the sandbox boundary. This allows execution of arbitrary O
Oct 31, 2026 · GitHub Advisory Database
Fix available
flowise fixed in 3.1.3; flowise-components fixed in 3.1.3
Oct 31, 2026 · GitHub Advisory Database
Fix available
flowise fixed in 3.1.3
Oct 31, 2026 · GitHub Advisory Database
Fix available
flowise-components fixed in 3.1.3
Oct 31, 2026 · GitHub Advisory Database
Updated
Flowise (packages flowise and flowise-components) in versions <= 3.1.2 contain a sandbox escape in the JavaScript sandbox. An authenticated user with access to the endpoint can escape the sandbox by supplying attacker-controlled executablePath and args parameters to puppeteer.launch(), which internally invokes child_process.spawn() outside the sandbox boundary. This allows execution of arbitrary O
Sources
- CVE.orgVulnerability recordCVE-2026-119978
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-119978
30-day exploitation probability 0.34%
first.org - GitHub Advisory DatabasePackage advisoryGHSA-9gvv-qjj3-2p6g
GitHub Advisory Database record mirrored by OSV.
github.com - OpenSSF OSV / OSV ScannerPackage advisoryGHSA-9gvv-qjj3-2p6g
Flowise NodeVM sandbox escape via puppeteer allowlist - authenticated RCE and arbitrary file read via Chromium
osv.dev
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 3, 2026
- GitHub Advisory DatabaseNov 1, 2026
- OpenSSF OSV / OSV ScannerNov 1, 2026
- CVE.orgOct 31, 2026