Vulnerability · CVE-2026-121437
Mistune from 3.3.0 before 3.3.4 contains a denial of service vulnerability that allows remote attackers to exhaust CPU through quadratic-time emphasis delimiter processing.
Published Nov 3, 2026 · catalog updated Nov 4, 2026 · Mistune from 3.3.0 before
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-121437. EPSS is 0.62%. Act only if a listed version of Mistune from 3.3.0 before is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Mistune from 3.3.0 before).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium—
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.62%
- Remediation
- Advisory link
- Affected products
- Debian:14 mistune · package pip
Mistune from 3.3.0 before 3.3.4 contains a denial of service vulnerability that allows remote attackers to exhaust CPU through quadratic-time emphasis delimiter processing. Attackers can submit small markdown documents with repeated patterns like "*a_b" to trigger an O(n²) index-fixup loop, stalling workers for seconds.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:14 mistune3.1.3-1, 3.1.4-1, 3.3.4-1
- package pipversion unspecified
How to fix CVE-2026-121437
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
Seen in 3.1.3-1 · 2 other packages on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-121437. EPSS is 0.62%. Act only if a listed version of Mistune from 3.3.0 before is installed.
Which versions are affected?
Compare what you have installed with 3.1.3-1, 3.1.4-1, 3.3.4-1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.62%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Nov 3, 2026 · OpenSSF OSV / OSV Scanner
Detected
Mistune from 3.3.0 before 3.3.4 contains a denial of service vulnerability that allows remote attackers to exhaust CPU through quadratic-time emphasis delimiter processing. Attackers can submit small markdown documents with repeated patterns like "*a_b" to trigger an O(n²) index-fixup loop, stalling workers for seconds.
Nov 4, 2026 · OpenSSF OSV / OSV Scanner
Updated
Mistune from 3.3.0 before 3.3.4 contains a denial of service vulnerability that allows remote attackers to exhaust CPU through quadratic-time emphasis delimiter processing. Attackers can submit small markdown documents with repeated patterns like "*a_b" to trigger an O(n²) index-fixup loop, stalling workers for seconds.
Sources
- CVE.orgVulnerability recordCVE-2026-121437
Official CVE identifier
cve.org - OpenSSF OSV / OSV ScannerPackage advisoryDEBIAN-CVE-2026-121437osv.dev
- Snyk Vulnerability DatabasePackage advisorySNYK-PYTHON-MISTUNE-22190629
Inefficient Algorithmic Complexity
security.snyk.io - Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-121437
Mistune from 3.3.0 before 3.3.4 contains a denial of service vulnerability that allows remote attackers to exhaust CPU through quadratic-time emphasis delimiter processing. Attackers can submit small markdown documents with repeated patterns like "*a_b" to trigger an O(n²) index-
osv.dev
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Snyk Vulnerability DatabaseNov 6, 2026
- CVE.orgNov 4, 2026
- Trivy Vulnerability DBNov 4, 2026
- OpenSSF OSV / OSV ScannerNov 4, 2026