Vulnerability · CVE-2026-121522
Possible panic from Git source resolver
Published Nov 3, 2026 · catalog updated Nov 3, 2026 · Red Hat Red Hat Enterprise Linux
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-121522. EPSS is 0.12%. Act only if a listed version of Red Hat Red Hat Enterprise Linux is installed.
Gaps on this record
- No version range is stored. A customer cannot check an installed version against this record.
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-121995 · High
- CVE-2026-121996 · High
- CVE-2026-121997 · High
- CVE-2026-121994 · High
- CVE-2026-111253 · Medium
- Severity
- Medium6.7
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.12%
- Remediation
- Advisory link
- Affected products
- vendor moby BuildKit
In BuildKit versions v0.26.0 through v0.34.1, a specific build definition that resolves metadata for the same Git source reference twice can cause the BuildKit daemon to panic and crash, interrupting builds handled by that daemon. The issue is fixed in v0.34.2.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor moby BuildKitversion unspecified
How to fix CVE-2026-121522
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
No version range is stored, so an installed version cannot be checked on this page.
Advisory
Open the bsi record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-121522. EPSS is 0.12%. Act only if a listed version of Red Hat Red Hat Enterprise Linux is installed.
Which versions are affected?
Affected version ranges are not on this record. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-248; CWE-476: NULL Pointer Dereference. EPSS 0.12%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Nov 4, 2026 · BSI CERT-Bund
Detected
CVE-2026-121522 is listed by BuildKit: Mehrere Schwachstellen.
Sources
- BSI CERT-BundGovernment advisoryCVE-2026-121522
BuildKit: Mehrere Schwachstellen
wid.cert-bund.de - CVE.orgVulnerability recordCVE-2026-121522
In BuildKit versions v0.26.0 through v0.34.1, a specific build definition that resolves metadata for the same Git source reference twice can cause the BuildKit daemon to panic and crash, interrupting builds handled by that daemon. The issue is fixed in v0.34.2.
cve.org - Red Hat Security DataVendor advisoryCVE-2026-121522
github.com/moby/buildkit: BuildKit: Denial of Service via duplicate Git source metadata resolution
access.redhat.com
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Red Hat Security DataNov 5, 2026
- CVE.orgNov 4, 2026
- BSI CERT-BundNov 4, 2026