Vulnerabilities

Vulnerability · CVE-2026-123158

OpenSSH: Schwachstelle ermöglicht Erlangen von Administratorrechten

Published Nov 5, 2026 · catalog updated Nov 6, 2026 · OpenBSD OpenSSH

Last checked Nov 6, 2026. A connected source was read within the last 7 days.

Patch now

CVE-2026-123158 is in the CISA known-exploited catalog. Confirm OpenBSD OpenSSH against the vendor advisory and apply that fix. The CVSS score does not change the priority.

Same product and reporting

Severity
High8.1
Known exploitation
CISA KEV and VulnCheck KEV
EPSS
0.98%
Remediation
Remediation guidance
Affected products
Alpine:v3.16 openssh · Alpine:v3.17 openssh · Alpine:v3.18 openssh · Alpine:v3.19 openssh · Alpine:v3.20 openssh · Alpine:v3.21 openssh

sshd in OpenSSH before 10.6p2 on Linux, when musl libc is used without PAM, lacks a workaround for a password authentication bypass (related to misinterpretation of whether a string is intended to be a password hash). For some configurations of accounts, any password between 256 and 1024 characters succeeds. An example of a platform using musl libc without PAM is Alpine Linux.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • Alpine:v3.16 openssh0 → 9.0_p1-r6
  • Alpine:v3.17 openssh0 → 9.1_p1-r7
  • Alpine:v3.18 openssh0 → 9.3_p2-r4
  • Alpine:v3.19 openssh0 → 9.6_p1-r3
  • Alpine:v3.20 openssh0 → 9.7_p1-r6
  • Alpine:v3.21 openssh0 → 9.9_p2-r1
  • Alpine:v3.22 openssh0 → 10.0_p1-r11
  • Alpine:v3.23 openssh0 → 10.2_p1-r1
  • Alpine:v3.24 openssh0 → 10.3_p1-r2
  • vendor OpenBSD OpenSSHversion unspecified

How to fix CVE-2026-123158

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

CVE-2026-123158 is in the CISA known-exploited catalog. Confirm OpenBSD OpenSSH against the vendor advisory and apply that fix. The CVSS score does not change the priority.

Which versions are affected?

Compare what you have installed with 0 → 9.0_p1-r6, 0 → 9.1_p1-r7, 0 → 9.3_p2-r4, 0 → 9.6_p1-r3, 0 → 9.7_p1-r6, 0 → 9.9_p2-r1. Apply remediations or mitigations per vendor instructions or discontinue use of the product if remediation or mitigations are unavailable.

What should an analyst verify?

No weakness class is stored. EPSS 0.98%. The CISA KEV listing is the exploitation evidence. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 6, 2026 · CISA KEV

    Known exploited

    Apply remediations or mitigations per vendor instructions or discontinue use of the product if remediation or mitigations are unavailable.

  2. Nov 6, 2026 · BSI CERT-Bund

    Detected

    OpenSSH: Schwachstelle ermöglicht Erlangen von Administratorrechten

  3. Nov 6, 2026 · Trivy Vulnerability DB

    Fix available

    openssh fixed in 9.0_p1-r6; openssh fixed in 9.1_p1-r7; openssh fixed in 9.3_p2-r4; openssh fixed in 9.6_p1-r3

  4. Nov 6, 2026 · Trivy Vulnerability DB

    Fix available

    openssh fixed in 9.0_p1-r6

  5. Nov 6, 2026 · Trivy Vulnerability DB

    Fix available

    openssh fixed in 9.1_p1-r7

  6. Nov 6, 2026 · Trivy Vulnerability DB

    Fix available

    openssh fixed in 9.3_p2-r4

  7. Nov 6, 2026 · Trivy Vulnerability DB

    Fix available

    openssh fixed in 9.6_p1-r3

  8. Nov 6, 2026 · Trivy Vulnerability DB

    Fix available

    openssh fixed in 9.7_p1-r6

  9. Nov 6, 2026 · Trivy Vulnerability DB

    Fix available

    openssh fixed in 9.9_p2-r1

  10. Nov 6, 2026 · Trivy Vulnerability DB

    Fix available

    openssh fixed in 10.0_p1-r11

  11. Nov 6, 2026 · Trivy Vulnerability DB

    Fix available

    openssh fixed in 10.2_p1-r1

  12. Nov 6, 2026 · Trivy Vulnerability DB

    Fix available

    openssh fixed in 10.3_p1-r2

  13. Nov 6, 2026 · Trivy Vulnerability DB

    Updated

    sshd in OpenSSH before 10.6p2 on Linux, when musl libc is used without PAM, lacks a workaround for a password authentication bypass (related to misinterpretation of whether a string is intended to be a password hash). For some configurations of accounts, any password between 256 and 1024 characters succeeds. An example of a platform using musl libc without PAM is Alpine Linux.

Sources

  • BSI CERT-BundGovernment advisoryCVE-2026-123158

    OpenSSH: Schwachstelle ermöglicht Erlangen von Administratorrechten

    wid.cert-bund.de
  • CVE.orgVulnerability recordCVE-2026-123158

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2026-123158

    30-day exploitation probability 0.98%

    first.org
  • Trivy Vulnerability DBPackage advisoryALPINE-CVE-2026-123158

    sshd in OpenSSH before 10.6p2 on Linux, when musl libc is used without PAM, lacks a workaround for a password authentication bypass (related to misinterpretation of whether a string is intended to be a password hash). For some configurations of accounts, any password between 256

    osv.dev
  • VulnCheck KEVConfirmed exploitationCVE-2026-123158

    sshd in OpenSSH before 10.6p2 on Linux, when musl libc is used without PAM, lacks a workaround for a password authentication bypass (related to misinterpretation of whether a string is intended to be a password hash). For some configurations of accounts, any password between 256

    vulncheck.com

References

Freshness

Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • VulnCheck KEVNov 6, 2026
  • FIRST EPSSNov 6, 2026
  • CVE.orgNov 6, 2026
  • Trivy Vulnerability DBNov 6, 2026
  • BSI CERT-BundNov 6, 2026