Vulnerability · CVE-2026-13426
github.com/mattermost/mattermost/server/public vulnerable to path traversal in API route construction
Published Jun 26, 2026 · catalog updated Nov 6, 2026 · github.com/mattermost/mattermost/server/public vulnerable to path
Last checked Nov 7, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-13426. EPSS is 0.29%. Act only if a listed version of github.com/mattermost/mattermost/server/public vulnerable to path is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (github.com/mattermost/mattermost/server/public vulnerable to path).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium5.4
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.29%
- Remediation
- Advisory link
- Affected products
- Go github.com/mattermost/mattermost/server/public
The Mattermost Go module github.com/mattermost/mattermost/server/public versions < v0.1.22 fail to validate path parameters when constructing API route paths which allows an attacker to redirect API calls to unintended endpoints via crafted IDs containing path traversal components. Mattermost Advisory ID: MMSA-2025-00532
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Go github.com/mattermost/mattermost/server/public0 → 0.1.22
How to fix CVE-2026-13426
Upgrade
CVE-2026-13426 lists a fix boundary at 0.1.22. Compare the installed build with that boundary before you change production.
Version check
Fixed in 0.1.22
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-13426. EPSS is 0.29%. Act only if a listed version of github.com/mattermost/mattermost/server/public vulnerable to path is installed.
Which versions are affected?
Compare what you have installed with 0 → 0.1.22. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-22: Path Traversal. EPSS 0.29%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jun 26, 2026 · Go Vulnerability Database
Detected
The Mattermost Go module github.com/mattermost/mattermost/server/public versions < v0.1.22 fail to validate path parameters when constructing API route paths which allows an attacker to redirect API calls to unintended endpoints via crafted IDs containing path traversal components. Mattermost Advisory ID: MMSA-2025-00532
Nov 3, 2026 · Go Vulnerability Database
Fix available
github.com/mattermost/mattermost/server/public fixed in 0.1.22
Nov 3, 2026 · Go Vulnerability Database
Fix available
github.com/mattermost/mattermost/server/public fixed in 0.1.22
Nov 3, 2026 · Go Vulnerability Database
Updated
The Mattermost Go module github.com/mattermost/mattermost/server/public versions < v0.1.22 fail to validate path parameters when constructing API route paths which allows an attacker to redirect API calls to unintended endpoints via crafted IDs containing path traversal components. Mattermost Advisory ID: MMSA-2025-00532
Nov 6, 2026 · GitHub Advisory Database
Updated
The Mattermost Go module github.com/mattermost/mattermost/server/public versions < v0.1.22 fail to validate path parameters when constructing API route paths which allows an attacker to redirect API calls to unintended endpoints via crafted IDs containing path traversal components. Mattermost Advisory ID: MMSA-2025-00532
Sources
- CVE.orgVulnerability recordCVE-2026-13426
Official CVE identifier
cve.org - GitHub Advisory DatabasePackage advisoryGHSA-72v2-v53v-4qmm
GitHub Advisory Database record mirrored by OSV.
github.com - Go Vulnerability DatabasePackage advisoryGHSA-72v2-v53v-4qmm
github.com/mattermost/mattermost/server/public vulnerable to path traversal in API route construction
osv.dev - Go Vulnerability DatabasePackage advisoryGO-2026-6910
Path traversal in API route construction in github.com/mattermost/mattermost/server/public
osv.dev - OpenSSF OSV / OSV ScannerPackage advisoryGHSA-72v2-v53v-4qmm
github.com/mattermost/mattermost/server/public vulnerable to path traversal in API route construction
osv.dev - OpenSSF OSV / OSV ScannerPackage advisoryGO-2026-6910
Path traversal in API route construction in github.com/mattermost/mattermost/server/public
osv.dev
References
Freshness
Last verified in this catalog Nov 7, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Go Vulnerability DatabaseNov 7, 2026
- Go Vulnerability DatabaseNov 7, 2026
- GitHub Advisory DatabaseNov 6, 2026
- OpenSSF OSV / OSV ScannerNov 6, 2026
- OpenSSF OSV / OSV ScannerNov 6, 2026
- CVE.orgNov 4, 2026