Security incident · CVE-2026-19941
An inapplicable NSEC record may be accepted by a resolver as proof that no wildcard exists, which could allow an attacker at the same or an upstream level of the zone name to mask
Published Sep 16, 2026 · catalog updated Oct 28, 2026 · An inapplicable NSEC record
Last checked Oct 28, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-19941. EPSS is 0.23%. Act only if a listed version of An inapplicable NSEC record is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (An inapplicable NSEC record).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium5.9
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.23%
- Remediation
- Advisory link
- Affected products
- Debian:12 bind9 · Debian:13 bind9 · Debian:14 bind9
An inapplicable NSEC record may be accepted by a resolver as proof that no wildcard exists, which could allow an attacker at the same or an upstream level of the zone name to mask the existence of a victim's wildcard record. This issue affects BIND 9 versions 9.11.0 through 9.18.50, 9.20.0 through 9.20.27, 9.21.0 through 9.21.25, 9.11.3-S1 through 9.18.50-S1, and 9.20.9-S1 through 9.20.27-S1.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:12 bind90 → 1:9.18.49-1~deb12u3
- Debian:13 bind90 → 1:9.20.29-1~deb13u1
- Debian:14 bind90 → 1:9.20.29-1
How to fix CVE-2026-19941
Upgrade
CVE-2026-19941 lists a fix boundary at 1:9.18.49-1~deb12u3. Compare the installed build with that boundary before you change production.
Version check
Fixed in 1:9.18.49-1~deb12u3 · 2 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-19941. EPSS is 0.23%. Act only if a listed version of An inapplicable NSEC record is installed.
Which versions are affected?
Compare what you have installed with 0 → 1:9.18.49-1~deb12u3, 0 → 1:9.20.29-1~deb13u1, 0 → 1:9.20.29-1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.23%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Sep 16, 2026 · OpenSSF OSV / OSV Scanner
Detected
An inapplicable NSEC record may be accepted by a resolver as proof that no wildcard exists, which could allow an attacker at the same or an upstream level of the zone name to mask the existence of a victim's wildcard record. This issue affects BIND 9 versions 9.11.0 through 9.18.50, 9.20.0 through 9.20.27, 9.21.0 through 9.21.25, 9.11.3-S1 through 9.18.50-S1, and 9.20.9-S1 through 9.20.27-S1.
Oct 28, 2026 · OpenSSF OSV / OSV Scanner
Fix available
bind9 fixed in 1:9.18.49-1~deb12u3; bind9 fixed in 1:9.20.29-1~deb13u1; bind9 fixed in 1:9.20.29-1
Oct 28, 2026 · OpenSSF OSV / OSV Scanner
Fix available
bind9 fixed in 1:9.18.49-1~deb12u3
Oct 28, 2026 · OpenSSF OSV / OSV Scanner
Fix available
bind9 fixed in 1:9.20.29-1~deb13u1
Oct 28, 2026 · OpenSSF OSV / OSV Scanner
Fix available
bind9 fixed in 1:9.20.29-1
Oct 28, 2026 · OpenSSF OSV / OSV Scanner
Updated
An inapplicable NSEC record may be accepted by a resolver as proof that no wildcard exists, which could allow an attacker at the same or an upstream level of the zone name to mask the existence of a victim's wildcard record. This issue affects BIND 9 versions 9.11.0 through 9.18.50, 9.20.0 through 9.20.27, 9.21.0 through 9.21.25, 9.11.3-S1 through 9.18.50-S1, and 9.20.9-S1 through 9.20.27-S1.
Sources
- CVE.orgVulnerability recordCVE-2026-19941
Official CVE identifier
cve.org - OpenSSF OSV / OSV ScannerPackage advisoryDEBIAN-CVE-2026-19941osv.dev
References
Freshness
Last verified in this catalog Oct 28, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 28, 2026
- OpenSSF OSV / OSV ScannerOct 28, 2026