Vulnerability · CVE-2026-21579
This High severity Information Disclosure vulnerability was introduced in versions 7.17.0, 7.19.0, 8.5.0, 8.9.0, 9.0.1, 9.1.0, 9.2.0, 10.0.2, 10.1.0, and 10.2.0 of Con…
Published Jul 21, 2026 · catalog updated Oct 24, 2026 · confluence data center
Last checked Oct 25, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-21579. EPSS is 0.44%. Act only if a listed version of confluence data center is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-21577 · High
- Severity
- High8.2
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.44%
- Remediation
- Version ranges on file
- Affected products
- cpe atlassian/confluence data center
This High severity Information Disclosure vulnerability was introduced in versions 7.17.0, 7.19.0, 8.5.0, 8.9.0, 9.0.1, 9.1.0, 9.2.0, 10.0.2, 10.1.0, and 10.2.0 of Confluence Data Center. This Information Disclosure vulnerability, with a CVSS Score of 8.2, allows an unauthenticated attacker to view sensitive information via an Information Disclosure vulnerability. Atlassian recommends that Confluence Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Confluence Data Center 9.2: Upgrade to a release greater than or equal to 9.2.22 Confluence Data Center 10.2: Upgrade to a release greater than or equal to 10.2.14 See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html]). You can download the latest version of Confluence Data Center from the download center ([https://www.atlassian.com/software/confluence/download-archives]). This vulnerability was reported via our Atlassian (Internal) program.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe atlassian/confluence data center>= 10.0.2, <= 10.0.3
- cpe atlassian/confluence data center>= 10.1.0, <= 10.1.2
- cpe atlassian/confluence data center>= 7.19.26, <= 7.19.30
- cpe atlassian/confluence data center>= 8.5.14, <= 8.5.31
- cpe atlassian/confluence data center>= 8.9.5, <= 8.9.8
- cpe atlassian/confluence data center>= 9.0.1, <= 9.0.3
- cpe atlassian/confluence data center>= 9.1.0, <= 9.1.1
- cpe atlassian/confluence data center>= 9.2.0, <= 9.2.21
How to fix CVE-2026-21579
Upgrade
CVE-2026-21579 lists a fix boundary at 10.0.3. Compare the installed build with that boundary before you change production.
Version check
Affected <= 10.0.3
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-21579. EPSS is 0.44%. Act only if a listed version of confluence data center is installed.
Which versions are affected?
Compare what you have installed with atlassian/confluence data center >= 10.0.2, <= 10.0.3; atlassian/confluence data center >= 10.1.0, <= 10.1.2; atlassian/confluence data center >= 7.19.26, <= 7.19.30; atlassian/confluence data center >= 8.5.14, <= 8.5.31. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-200: Exposure of Sensitive Information. EPSS 0.44%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jul 21, 2026 · NIST NVD
Detected
This High severity Information Disclosure vulnerability was introduced in versions 7.17.0, 7.19.0, 8.5.0, 8.9.0, 9.0.1, 9.1.0, 9.2.0, 10.0.2, 10.1.0, and 10.2.0 of Confluence Data Center. This Information Disclosure vulnerability, with a CVSS Score of 8.2, allows an unauthenticated attacker to view sensitive information via an Information Disclosure vulnerability. Atlassian recommends that Conflue
Oct 24, 2026 · NIST NVD
Updated
This High severity Information Disclosure vulnerability was introduced in versions 7.17.0, 7.19.0, 8.5.0, 8.9.0, 9.0.1, 9.1.0, 9.2.0, 10.0.2, 10.1.0, and 10.2.0 of Confluence Data Center. This Information Disclosure vulnerability, with a CVSS Score of 8.2, allows an unauthenticated attacker to view sensitive information via an Information Disclosure vulnerability. Atlassian recommends that Conflue
Sources
- CVE.orgVulnerability recordCVE-2026-21579
Official CVE identifier
cve.org - NIST NVDVulnerability recordCVE-2026-21579
This High severity Information Disclosure vulnerability was introduced in versions 7.17.0, 7.19.0, 8.5.0, 8.9.0, 9.0.1, 9.1.0, 9.2.0, 10.0.2, 10.1.0, and 10.2.0 of Confluence Data Center. This Information Disclosure vulnerability, with a CVSS Score of 8.2, allows an unauthenti
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 25, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 24, 2026
- NIST NVDOct 24, 2026