Vulnerabilities

Security fix · CVE-2026-22034

Snuffleupagus is a module that raises the cost of attacks against website by killing bug classes and providing a virtual patching system.

Published Jan 8, 2026 · catalog updated Jan 8, 2026 · Snuffleupagus is a module

Last checked Nov 6, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-22034. EPSS is 0.71%. Act only if a listed version of Snuffleupagus is a module is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Snuffleupagus is a module).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
Critical9.2
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.71%
Remediation
Version ranges on file
Affected products
vendor jvoisin snuffleupagus < 0.13.0

Snuffleupagus is a module that raises the cost of attacks against website by killing bug classes and providing a virtual patching system. On deployments of Snuffleupagus prior to version 0.13.0 with the non-default upload validation feature enabled and configured to use one of the upstream validation scripts based on Vulcan Logic Disassembler (VLD) while the VLD extension is not available to the CLI SAPI, all files from multipart POST requests are evaluated as PHP code. The issue was fixed in version 0.13.0.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor jvoisin snuffleupagus < 0.13.0< 0.13.0

How to fix CVE-2026-22034

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-22034. EPSS is 0.71%. Act only if a listed version of Snuffleupagus is a module is installed.

Which versions are affected?

Compare what you have installed with jvoisin snuffleupagus < 0.13.0 < 0.13.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.71%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Jan 8, 2026 · EUVD

    Detected

    Snuffleupagus is a module that raises the cost of attacks against website by killing bug classes and providing a virtual patching system. On deployments of Snuffleupagus prior to version 0.13.0 with the non-default upload validation feature enabled and configured to use one of the upstream validation scripts based on Vulcan Logic Disassembler (VLD) while the VLD extension is not available to the C

  2. Jan 8, 2026 · EUVD

    Updated

    Snuffleupagus is a module that raises the cost of attacks against website by killing bug classes and providing a virtual patching system. On deployments of Snuffleupagus prior to version 0.13.0 with the non-default upload validation feature enabled and configured to use one of the upstream validation scripts based on Vulcan Logic Disassembler (VLD) while the VLD extension is not available to the C

Sources

  • CVE.orgVulnerability recordCVE-2026-22034

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2026-22034

    30-day exploitation probability 0.71%

    first.org
  • EUVDVulnerability recordEUVD-2026-1676

    Snuffleupagus is a module that raises the cost of attacks against website by killing bug classes and providing a virtual patching system. On deployments of Snuffleupagus prior to version 0.13.0 with the non-default upload validation feature enabled and configured to use one of th

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 6, 2026
  • CVE.orgOct 31, 2026
  • EUVDOct 30, 2026