Vulnerability · CVE-2026-22610
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages.
Published Jan 10, 2026 · catalog updated Jun 2, 2026 · Angular is a development
Last checked Nov 1, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-22610. EPSS is 0.44%. Act only if a listed version of Angular is a development is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Angular is a development).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-41423 · High
- CVE-2026-27970 · High
- CVE-2025-66412 · High
- CVE-2025-66035 · High
- CVE-2025-59052 · High
- Severity
- High8.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.44%
- Remediation
- Version ranges on file
- Affected products
- vendor angular angular 20.0.0-next.0, < 20.3.16
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0, a cross-site scripting (XSS) vulnerability has been identified in the Angular Template Compiler. The vulnerability exists because Angular’s internal sanitization schema fails to recognize the href and xlink:href attributes of SVG elements as a Resource URL context. This issue has been patched in versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor angular angular 20.0.0-next.0, < 20.3.1620.0.0-next.0, < 20.3.16
How to fix CVE-2026-22610
Upgrade
CVE-2026-22610 lists a fix boundary at 20.3.16. Compare the installed build with that boundary before you change production.
Version check
Affected < 20.3.16
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-22610. EPSS is 0.44%. Act only if a listed version of Angular is a development is installed.
Which versions are affected?
Compare what you have installed with angular angular 20.0.0-next.0, < 20.3.16 20.0.0-next.0, < 20.3.16. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.44%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jan 10, 2026 · EUVD
Detected
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0, a cross-site scripting (XSS) vulnerability has been identified in the Angular Template Compiler. The vulnerability exists because Angular’s internal sanitization schema fails to recognize the href and xlink:
Jun 2, 2026 · EUVD
Updated
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0, a cross-site scripting (XSS) vulnerability has been identified in the Angular Template Compiler. The vulnerability exists because Angular’s internal sanitization schema fails to recognize the href and xlink:
Sources
- CVE.orgVulnerability recordCVE-2026-22610
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-22610
30-day exploitation probability 0.44%
first.org - EUVDVulnerability recordEUVD-2026-1698
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0, a cross-site scripting (XSS) vulnerability has been identified in the Angular Template
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 1, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 1, 2026
- CVE.orgOct 29, 2026
- EUVDOct 29, 2026