Security research · CVE-2026-22774
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job.
Published Jan 15, 2026 · catalog updated Jul 15, 2026 · Svelte devalue is a
Last checked Oct 29, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-22774. EPSS is 0.63%. Act only if a listed version of Svelte devalue is a is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Svelte devalue is a).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-30226 · Medium
- CVE-2026-22775 · High
- CVE-2025-57820 · High
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.63%
- Remediation
- Version ranges on file
- Affected products
- vendor sveltejs devalue 5.3.0, < 5.6.2
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From 5.3.0 to 5.6.1, certain inputs can cause devalue.parse to consume excessive CPU time and/or memory, potentially leading to denial of service in systems that parse input from untrusted sources. This affects applications using devalue.parse on externally-supplied data. The root cause is the typed array hydration expecting an ArrayBuffer as input, but not checking the assumption before creating the typed array. This vulnerability is fixed in 5.6.2.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor sveltejs devalue 5.3.0, < 5.6.25.3.0, < 5.6.2
How to fix CVE-2026-22774
Upgrade
CVE-2026-22774 lists a fix boundary at 5.6.2. Compare the installed build with that boundary before you change production.
Version check
Affected < 5.6.2
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-22774. EPSS is 0.63%. Act only if a listed version of Svelte devalue is a is installed.
Which versions are affected?
Compare what you have installed with sveltejs devalue 5.3.0, < 5.6.2 5.3.0, < 5.6.2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.63%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jan 15, 2026 · EUVD
Detected
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From 5.3.0 to 5.6.1, certain inputs can cause devalue.parse to consume excessive CPU time and/or memory, potentially leading to denial of service in systems that parse input from untrusted sources. This affects applications using devalue.parse on externally-supplied data. Th
Jul 15, 2026 · EUVD
Updated
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From 5.3.0 to 5.6.1, certain inputs can cause devalue.parse to consume excessive CPU time and/or memory, potentially leading to denial of service in systems that parse input from untrusted sources. This affects applications using devalue.parse on externally-supplied data. Th
Sources
- CVE.orgVulnerability recordCVE-2026-22774
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-22774
30-day exploitation probability 0.63%
first.org - EUVDVulnerability recordEUVD-2026-2790
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From 5.3.0 to 5.6.1, certain inputs can cause devalue.parse to consume excessive CPU time and/or memory, potentially leading to denial of service in system
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 29, 2026
- FIRST EPSSOct 29, 2026
- EUVDOct 29, 2026