Vulnerability · CVE-2026-22778
vLLM is an inference and serving engine for large language models (LLMs).
Published Feb 2, 2026 · catalog updated Jul 15, 2026 · vLLM is an inference
Last checked Nov 7, 2026. A connected source was read within the last 7 days.
Check this week
CVE-2026-22778 is not in CISA KEV. FIRST estimates a 18.29% chance of exploitation in the next 30 days. Check whether you run vLLM is an inference.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (vLLM is an inference).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-115917 · Medium
- CVE-2026-100653 · High
- CVE-2026-44223 · Medium
- CVE-2026-44222 · High
- CVE-2026-7141 · Low
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 18.29%
- Remediation
- Version ranges on file
- Affected products
- vendor vllm-project vllm 0.8.3, < 0.14.1
vLLM is an inference and serving engine for large language models (LLMs). From 0.8.3 to before 0.14.1, when an invalid image is sent to vLLM's multimodal endpoint, PIL throws an error. vLLM returns this error to the client, leaking a heap address. With this leak, we reduce ASLR from 4 billion guesses to ~8 guesses. This vulnerability can be chained a heap overflow with JPEG2000 decoder in OpenCV/FFmpeg to achieve remote code execution. This vulnerability is fixed in 0.14.1.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor vllm-project vllm 0.8.3, < 0.14.10.8.3, < 0.14.1
How to fix CVE-2026-22778
Upgrade
CVE-2026-22778 lists a fix boundary at 0.14.1. Compare the installed build with that boundary before you change production.
Version check
Affected < 0.14.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
CVE-2026-22778 is not in CISA KEV. FIRST estimates a 18.29% chance of exploitation in the next 30 days. Check whether you run vLLM is an inference.
Which versions are affected?
Compare what you have installed with vllm-project vllm 0.8.3, < 0.14.1 0.8.3, < 0.14.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 18.29%. There is no CISA KEV listing. A public exploit reference is linked in Sources. That is not the same as confirmed exploitation. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Feb 2, 2026 · EUVD
Detected
vLLM is an inference and serving engine for large language models (LLMs). From 0.8.3 to before 0.14.1, when an invalid image is sent to vLLM's multimodal endpoint, PIL throws an error. vLLM returns this error to the client, leaking a heap address. With this leak, we reduce ASLR from 4 billion guesses to ~8 guesses. This vulnerability can be chained a heap overflow with JPEG2000 decoder in OpenCV/F
Jul 15, 2026 · EUVD
Updated
vLLM is an inference and serving engine for large language models (LLMs). From 0.8.3 to before 0.14.1, when an invalid image is sent to vLLM's multimodal endpoint, PIL throws an error. vLLM returns this error to the client, leaking a heap address. With this leak, we reduce ASLR from 4 billion guesses to ~8 guesses. This vulnerability can be chained a heap overflow with JPEG2000 decoder in OpenCV/F
Sources
- CVE.orgVulnerability recordCVE-2026-22778
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-22778
30-day exploitation probability 18.29%
first.org - EUVDVulnerability recordEUVD-2026-5277
vLLM is an inference and serving engine for large language models (LLMs). From 0.8.3 to before 0.14.1, when an invalid image is sent to vLLM's multimodal endpoint, PIL throws an error. vLLM returns this error to the client, leaking a heap address. With this leak, we reduce ASLR f
euvd.enisa.europa.eu - Metasploit ModulesPublic exploit moduleauxiliary_scanner/http/vllm_multimodal_info_leak
Public module reference (normal). Module source is not copied into this catalog.
rapid7.com - urlscan.ioThreat intelligenceCVE-2026-22778urlscan.io
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- urlscan.ioNov 7, 2026
- Metasploit ModulesNov 7, 2026
- FIRST EPSSNov 5, 2026
- CVE.orgNov 4, 2026
- EUVDNov 2, 2026