Vulnerabilities

Vulnerability · CVE-2026-24098

Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Da

Published Feb 9, 2026 · catalog updated Nov 3, 2026 · Apache Airflow versions 3.0.0

Last checked Nov 3, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-24098. EPSS is 0.83%. Act only if a listed version of Apache Airflow versions 3.0.0 is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Apache Airflow versions 3.0.0).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium6.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.83%
Remediation
Version ranges on file
Affected products
cpe apache/airflow · vendor Apache Software Foundation Apache Airflow 3.0.0 <3.1.7

Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this issue

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe apache/airflow< 3.1.7
  • vendor Apache Software Foundation Apache Airflow 3.0.0 <3.1.73.0.0 <3.1.7

How to fix CVE-2026-24098

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-24098. EPSS is 0.83%. Act only if a listed version of Apache Airflow versions 3.0.0 is installed.

Which versions are affected?

Compare what you have installed with Apache Software Foundation Apache Airflow 3.0.0 <3.1.7 3.0.0 <3.1.7. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-200: Exposure of Sensitive Information. EPSS 0.83%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Feb 9, 2026 · Monitored products — high

    Detected

    Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this issue

  2. Jun 17, 2026 · Monitored products — high

    Updated

    Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this issue

  3. Nov 3, 2026 · NIST NVD

    Updated

    Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this issue

Sources

  • EUVDVulnerability recordEUVD-2026-6455

    Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this

    euvd.enisa.europa.eu
  • Monitored products — highVendor advisoryCVE-2026-24098

    Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this issue

    nvd.nist.gov
  • NIST NVDVulnerability recordCVE-2026-24098

    Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves thi

    nvd.nist.gov

References

Freshness

Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • NIST NVDNov 3, 2026
  • EUVDNov 2, 2026
  • Monitored products — highNov 2, 2026