Vulnerability · CVE-2026-24734
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat.
Published Feb 17, 2026 · catalog updated Jul 15, 2026 · Improper Input Validation vulnerability
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-24734. EPSS is 0.57%. Act only if a listed version of Improper Input Validation vulnerability is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Improper Input Validation vulnerability).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-73180 · Medium
- CVE-2026-68763 · High
- CVE-2026-68569 · High
- CVE-2026-68525 · Critical
- CVE-2026-66422 · High
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.57%
- Remediation
- Version ranges on file
- Affected products
- cpe apache/tomcat
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native: from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114. The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected. Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue. Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apache/tomcat10.1.0
- cpe apache/tomcat< 10.1.52
- cpe apache/tomcat< 11.0.18
- cpe apache/tomcat< 9.0.115
How to fix CVE-2026-24734
Upgrade
CVE-2026-24734 lists a fix boundary at 10.1.52. Compare the installed build with that boundary before you change production.
Version check
Affected < 10.1.52
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-24734. EPSS is 0.57%. Act only if a listed version of Improper Input Validation vulnerability is installed.
Which versions are affected?
Compare what you have installed with 10.1.0, < 10.1.52, < 11.0.18, < 9.0.115. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-20: Improper Input Validation; CWE-295: Improper Certificate Validation. EPSS 0.57%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Feb 17, 2026 · Monitored products — critical
Detected
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native: from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apac
Jul 15, 2026 · Monitored products — critical
Updated
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native: from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apac
Sources
- CVE.orgVulnerability recordCVE-2026-24734
Official CVE identifier
cve.org - Monitored products — criticalVendor advisoryCVE-2026-24734
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native: from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apac
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — criticalNov 3, 2026