Vulnerability · CVE-2026-25957
Cube is a semantic layer for building data applications.
Published Feb 9, 2026 · catalog updated Feb 11, 2026 · Cube is a semantic
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-25957. EPSS is 0.43%. Act only if a listed version of Cube is a semantic is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Cube is a semantic).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-25958 · High
- CVE-2018-25156 · Medium
- Severity
- Medium6.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.43%
- Remediation
- Version ranges on file
- Affected products
- vendor cube-js cube 1.5.0, < 1.5.13
Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor cube-js cube 1.5.0, < 1.5.131.5.0, < 1.5.13
How to fix CVE-2026-25957
Upgrade
CVE-2026-25957 lists a fix boundary at 1.5.13. Compare the installed build with that boundary before you change production.
Version check
Affected < 1.5.13
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-25957. EPSS is 0.43%. Act only if a listed version of Cube is a semantic is installed.
Which versions are affected?
Compare what you have installed with cube-js cube 1.5.0, < 1.5.13 1.5.0, < 1.5.13. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.43%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Feb 9, 2026 · EUVD
Detected
Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.
Feb 11, 2026 · EUVD
Updated
Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.
Sources
- CVE.orgVulnerability recordCVE-2026-25957
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-25957
30-day exploitation probability 0.43%
first.org - EUVDVulnerability recordEUVD-2026-6246
Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 5, 2026
- CVE.orgNov 4, 2026
- EUVDNov 3, 2026