Vulnerabilities

Vulnerability · CVE-2026-35560

Improper certificate validation in the identity provider connection components in Amazon Athena ODBC driver before 2.1.0.0 might allow a man-in-the-middle threat actor…

Published Apr 3, 2026 · catalog updated Oct 20, 2026 · athena odbc

Last checked Nov 6, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-35560. EPSS is 0.28%. Act only if a listed version of athena odbc is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Critical9.1
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.28%
Remediation
Version ranges on file
Affected products
cpe amazon/athena odbc

Improper certificate validation in the identity provider connection components in Amazon Athena ODBC driver before 2.1.0.0 might allow a man-in-the-middle threat actor to intercept authentication credentials due to insufficient default transport security when connecting to identity providers. This only applies to connections with external identity providers and does not apply to connections with Athena. To remediate this issue, users should upgrade to version 2.1.0.0.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe amazon/athena odbc< 2.1.0.0

How to fix CVE-2026-35560

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-35560. EPSS is 0.28%. Act only if a listed version of athena odbc is installed.

Which versions are affected?

Compare what you have installed with amazon/athena odbc < 2.1.0.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-295: Improper Certificate Validation. EPSS 0.28%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Apr 3, 2026 · NIST NVD

    Detected

    Improper certificate validation in the identity provider connection components in Amazon Athena ODBC driver before 2.1.0.0 might allow a man-in-the-middle threat actor to intercept authentication credentials due to insufficient default transport security when connecting to identity providers. This only applies to connections with external identity providers and does not apply to connections with A

  2. Jul 24, 2026 · NIST NVD

    Updated

    Improper certificate validation in the identity provider connection components in Amazon Athena ODBC driver before 2.1.0.0 might allow a man-in-the-middle threat actor to intercept authentication credentials due to insufficient default transport security when connecting to identity providers. This only applies to connections with external identity providers and does not apply to connections with A

  3. Oct 20, 2026 · NIST NVD

    Updated

    Improper certificate validation in the identity provider connection components in Amazon Athena ODBC driver before 2.1.0.0 might allow a man-in-the-middle threat actor to intercept authentication credentials due to insufficient default transport security when connecting to identity providers. This only applies to connections with external identity providers and does not apply to connections with A

Sources

  • CVE.orgVulnerability recordCVE-2026-35560

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2026-35560

    30-day exploitation probability 0.28%

    first.org
  • NIST NVDVulnerability recordCVE-2026-35560

    Improper certificate validation in the identity provider connection components in Amazon Athena ODBC driver before 2.1.0.0 might allow a man-in-the-middle threat actor to intercept authentication credentials due to insufficient default transport security when connecting to identi

    nvd.nist.gov

References

Freshness

Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 6, 2026
  • NIST NVDOct 21, 2026
  • CVE.orgOct 16, 2026