Security incident · CVE-2026-45049
OpenAM Unauthenticated Session Hijacking via Information Exposure in CDCServlet
Published Jun 23, 2026 · catalog updated Oct 28, 2026 · OpenAM Unauthenticated Session Hijacking
Last checked Oct 30, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-45049. EPSS is 0.33%. Act only if a listed version of OpenAM Unauthenticated Session Hijacking is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (OpenAM Unauthenticated Session Hijacking).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High8.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.33%
- Remediation
- Advisory link
- Affected products
- Maven org.openidentityplatform.openam:openam-federation
## Summary **Description** An Information Exposure Through Sent Data (CWE-201) issue in OpenAM's Cross-Domain Single Sign-On (CDSSO) servlet allows a logged-in user's raw OpenAM session token to be POSTed to an attacker-controlled URL. This impacts OpenAM Community Edition through version 16.0.6. This issue was patched in version 16.1.1. An attacker who can induce a logged-in victim to visit a crafted URL may receive the victim's session credential, which could enable session hijacking. ## Impact OpenAM deployments through version 16.0.6 that have CDSSO enabled are potentially affected. The CDSSO component is commonly enabled in multi-domain deployments. Exploitation requires user interaction — an authenticated user must be induced to visit an attacker-crafted URL — and is further gated on a non-default configuration being absent. ## Patch This has been patched in OpenAM Community Edition version 16.1.1. Users are encouraged to update to the latest release.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Maven org.openidentityplatform.openam:openam-federation0 → 16.1.1
How to fix CVE-2026-45049
Upgrade
CVE-2026-45049 lists a fix boundary at 16.1.1. Compare the installed build with that boundary before you change production.
Version check
Fixed in 16.1.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-45049. EPSS is 0.33%. Act only if a listed version of OpenAM Unauthenticated Session Hijacking is installed.
Which versions are affected?
Compare what you have installed with 0 → 16.1.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-201. EPSS 0.33%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jun 23, 2026 · GitHub Advisory Database
Detected
## Summary **Description** An Information Exposure Through Sent Data (CWE-201) issue in OpenAM's Cross-Domain Single Sign-On (CDSSO) servlet allows a logged-in user's raw OpenAM session token to be POSTed to an attacker-controlled URL. This impacts OpenAM Community Edition through version 16.0.6. This issue was patched in version 16.1.1. An attacker who can induce a logged-in victim to visit a cra
Oct 28, 2026 · GitHub Advisory Database
Fix available
org.openidentityplatform.openam:openam-federation fixed in 16.1.1
Oct 28, 2026 · GitHub Advisory Database
Fix available
org.openidentityplatform.openam:openam-federation fixed in 16.1.1
Oct 28, 2026 · GitHub Advisory Database
Updated
## Summary **Description** An Information Exposure Through Sent Data (CWE-201) issue in OpenAM's Cross-Domain Single Sign-On (CDSSO) servlet allows a logged-in user's raw OpenAM session token to be POSTed to an attacker-controlled URL. This impacts OpenAM Community Edition through version 16.0.6. This issue was patched in version 16.1.1. An attacker who can induce a logged-in victim to visit a cra
Sources
- CVE.orgVulnerability recordCVE-2026-45049
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-45049
30-day exploitation probability 0.33%
first.org - GitHub Advisory DatabasePackage advisoryGHSA-r9pv-5rpp-vm8g
GitHub Advisory Database record mirrored by OSV.
github.com - OpenSSF OSV / OSV ScannerPackage advisoryGHSA-r9pv-5rpp-vm8g
OpenAM Unauthenticated Session Hijacking via Information Exposure in CDCServlet
osv.dev
References
Freshness
Last verified in this catalog Oct 30, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 30, 2026
- CVE.orgOct 29, 2026
- GitHub Advisory DatabaseOct 29, 2026
- OpenSSF OSV / OSV ScannerOct 29, 2026