Vulnerabilities

Vulnerability · CVE-2026-45070

Merge pull request #831 from nicolas-grekas/advisory-cve-2026-45070

Published Jul 14, 2026 · catalog updated Jul 16, 2026 · PHP Packagist

Last checked Oct 30, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-45070. EPSS is 0.39%. Act only if a listed version of PHP Packagist is installed.

Gaps on this record

  • No version range is stored. A customer cannot check an installed version against this record.
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium6.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.39%
Remediation
Advisory link
Affected products
vendor symfony mime · vendor symfony symfony

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Mime\Header\ParameterizedHeader validates and encodes parameter values but emits parameter names verbatim, allowing a caller that derives a parameter name from untrusted input to include CRLF or other non-token bytes and inject additional headers into rendered structured mail headers such as Content-Type or Content-Disposition. This issue is reported as fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor symfony mimeversion unspecified
  • vendor symfony symfonyversion unspecified

How to fix CVE-2026-45070

  • No stored fix

    No vendor fix text is stored. Use the linked advisory before you change production.

  • Version check

    No version range is stored, so an installed version cannot be checked on this page.

  • Advisory

    Open the cve_org record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-45070. EPSS is 0.39%. Act only if a listed version of PHP Packagist is installed.

Which versions are affected?

Affected version ranges are not on this record. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-93. EPSS 0.39%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Jul 16, 2026 · CVE.org

    Updated

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Mime\Header\ParameterizedHeader validates and encodes parameter values but emits parameter names verbatim, allowing a caller that derives a parameter name from untrusted input to include CRLF or other non-token bytes and inject additional

  2. Oct 28, 2026 · PHP Security Advisories

    Detected

    Merge pull request #831 from nicolas-grekas/advisory-cve-2026-45070 Fix the patched versions of CVE-2026-45070

Sources

  • CVE.orgVulnerability recordCVE-2026-45070

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Mime\Header\ParameterizedHeader validates and encodes parameter values but emits parameter names verbatim, allowing a c

    cve.org
  • PHP Security AdvisoriesVendor advisoryCVE-2026-45070

    Merge pull request #831 from nicolas-grekas/advisory-cve-2026-45070 Fix the patched versions of CVE-2026-45070

    github.com

References

Freshness

Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • PHP Security AdvisoriesOct 30, 2026
  • CVE.orgOct 29, 2026