Vulnerabilities

Vulnerability · CVE-2026-48962

IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob.

Published May 27, 2026 · catalog updated Nov 3, 2026 · IO::Compress versions before 2.220

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-48962. EPSS is 0.44%. Act only if a listed version of IO::Compress versions before 2.220 is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (IO::Compress versions before 2.220).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
High7.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.44%
Remediation
Advisory link
Affected products
Alpine:v3.24 perl

IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob. _parseOutputGlob() wraps the caller-supplied output glob string in double quotes and stores it in the parser state; _getFiles() then runs the stored expression through eval STRING. A literal double quote in the output glob closes the dquote wrapper, and the characters that follow are evaluated as Perl. Arbitrary Perl in the output glob executes at the calling process's privilege.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • Alpine:v3.24 perl0 → 5.42.3-r0

How to fix CVE-2026-48962

  • Upgrade

    CVE-2026-48962 lists a fix boundary at 5.42.3-r0. Compare the installed build with that boundary before you change production.

  • Version check

    Fixed in 5.42.3-r0

  • Advisory

    Open the cve_org record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-48962. EPSS is 0.44%. Act only if a listed version of IO::Compress versions before 2.220 is installed.

Which versions are affected?

Compare what you have installed with 0 → 5.42.3-r0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.44%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. May 27, 2026 · Trivy Vulnerability DB

    Detected

    IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob. _parseOutputGlob() wraps the caller-supplied output glob string in double quotes and stores it in the parser state; _getFiles() then runs the stored expression through eval STRING. A literal double quote in the output glob closes the dquote wrapper, and the characters

  2. Nov 3, 2026 · Trivy Vulnerability DB

    Fix available

    perl fixed in 5.42.3-r0

  3. Nov 3, 2026 · Trivy Vulnerability DB

    Fix available

    perl fixed in 5.42.3-r0

  4. Nov 3, 2026 · Trivy Vulnerability DB

    Updated

    IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob. _parseOutputGlob() wraps the caller-supplied output glob string in double quotes and stores it in the parser state; _getFiles() then runs the stored expression through eval STRING. A literal double quote in the output glob closes the dquote wrapper, and the characters

Sources

  • CVE.orgVulnerability recordCVE-2026-48962

    Official CVE identifier

    cve.org
  • Trivy Vulnerability DBPackage advisoryALPINE-CVE-2026-48962

    IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob. _parseOutputGlob() wraps the caller-supplied output glob string in double quotes and stores it in the parser state; _getFiles() then runs the stored

    osv.dev

References

Freshness

Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • Trivy Vulnerability DBNov 4, 2026
  • CVE.orgNov 4, 2026