Vulnerability · CVE-2026-55203
HAProxy through 3.4.0, fixed in commit 5985276, contains an integer overflow vulnerability in the fcgi_conn structure's drl field that allows buffer misparse as new FCGI record hea
Published Jun 18, 2026 · catalog updated Oct 26, 2026 · HAProxy through 3.4.0, fixed
Last checked Nov 1, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-55203. EPSS is 0.33%. Act only if a listed version of HAProxy through 3.4.0, fixed is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (HAProxy through 3.4.0, fixed).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Critical9.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.33%
- Remediation
- Advisory link
- Affected products
- Debian:12 haproxy · Debian:13 haproxy · Debian:14 haproxy
HAProxy through 3.4.0, fixed in commit 5985276, contains an integer overflow vulnerability in the fcgi_conn structure's drl field that allows buffer misparse as new FCGI record headers. When contentLength is 65535 and paddingLength is 1 or more, the drl field wraps to 0, causing incorrect record consumption and allowing malicious FastCGI backends to desynchronize the FCGI framing parser, potentially causing request routing errors, response smuggling, or memory safety issues.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:12 haproxy2.6.12-1, 2.6.12-1+deb12u1, 2.6.12-1+deb12u2
- Debian:13 haproxy3.0.11-1, 3.0.11-1+deb13u1, 3.0.11-1+deb13u2
- Debian:14 haproxy0 → 3.2.20-1
How to fix CVE-2026-55203
Upgrade
CVE-2026-55203 lists a fix boundary at 3.2.20-1. Compare the installed build with that boundary before you change production.
Version check
Fixed in 3.2.20-1 · 6 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-55203. EPSS is 0.33%. Act only if a listed version of HAProxy through 3.4.0, fixed is installed.
Which versions are affected?
Compare what you have installed with 2.6.12-1, 2.6.12-1+deb12u1, 2.6.12-1+deb12u2, 3.0.11-1, 3.0.11-1+deb13u1, 3.0.11-1+deb13u2, 0 → 3.2.20-1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.33%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jun 18, 2026 · Trivy Vulnerability DB
Detected
HAProxy through 3.4.0, fixed in commit 5985276, contains an integer overflow vulnerability in the fcgi_conn structure's drl field that allows buffer misparse as new FCGI record headers. When contentLength is 65535 and paddingLength is 1 or more, the drl field wraps to 0, causing incorrect record consumption and allowing malicious FastCGI backends to desynchronize the FCGI framing parser, potential
Oct 26, 2026 · Trivy Vulnerability DB
Fix available
haproxy fixed in 3.2.20-1
Oct 26, 2026 · Trivy Vulnerability DB
Fix available
haproxy fixed in 3.2.20-1
Oct 26, 2026 · Trivy Vulnerability DB
Updated
HAProxy through 3.4.0, fixed in commit 5985276, contains an integer overflow vulnerability in the fcgi_conn structure's drl field that allows buffer misparse as new FCGI record headers. When contentLength is 65535 and paddingLength is 1 or more, the drl field wraps to 0, causing incorrect record consumption and allowing malicious FastCGI backends to desynchronize the FCGI framing parser, potential
Sources
- CVE.orgVulnerability recordCVE-2026-55203
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-55203
30-day exploitation probability 0.33%
first.org - Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-55203
HAProxy through 3.4.0, fixed in commit 5985276, contains an integer overflow vulnerability in the fcgi_conn structure's drl field that allows buffer misparse as new FCGI record headers. When contentLength is 65535 and paddingLength is 1 or more, the drl field wraps to 0, causing
osv.dev
References
Freshness
Last verified in this catalog Nov 1, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 1, 2026
- CVE.orgOct 26, 2026
- Trivy Vulnerability DBOct 26, 2026