Vulnerability · CVE-2026-55957
Apache Tomcat: Authentication bypass with JNDIRealm and GSSAPI authenticated bind
Published Jun 29, 2026 · catalog updated Nov 4, 2026 · Apache Tomcat: Authentication bypass
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-55957. EPSS is 2.85%. Act only if a listed version of Apache Tomcat: Authentication bypass is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Apache Tomcat: Authentication bypass).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-73180 · Medium
- CVE-2026-68763 · High
- CVE-2026-68569 · High
- CVE-2026-68525 · Critical
- CVE-2026-66422 · High
- Severity
- High7.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 2.85%
- Remediation
- Version ranges on file
- Affected products
- Bitnami tomcat · cpe apache/tomcat
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Bitnami tomcat0 → 9.0.101
- cpe apache/tomcat< 10.1.37
- cpe apache/tomcat< 11.0.5
- cpe apache/tomcat< 9.0.101
How to fix CVE-2026-55957
Upgrade
CVE-2026-55957 lists a fix boundary at 9.0.101. Compare the installed build with that boundary before you change production.
Version check
Affected < 10.1.37
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-55957. EPSS is 2.85%. Act only if a listed version of Apache Tomcat: Authentication bypass is installed.
Which versions are affected?
Compare what you have installed with 0 → 9.0.101, < 10.1.37, < 11.0.5, < 9.0.101. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-304. EPSS 2.85%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jun 29, 2026 · Monitored products — critical
Detected
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Use
Oct 25, 2026 · Monitored products — critical
Updated
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Use
Nov 4, 2026 · GitHub Advisory Database
Fix available
tomcat fixed in 9.0.101
Nov 4, 2026 · GitHub Advisory Database
Fix available
tomcat fixed in 9.0.101
Nov 4, 2026 · GitHub Advisory Database
Updated
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0 through 11.0.4, from 10.1.0 through 10.1.36, from 9.0.0 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are re
Sources
- CVE.orgVulnerability recordCVE-2026-55957
Official CVE identifier
cve.org - GitHub Advisory DatabasePackage advisoryGHSA-7895-gffq-w6jq
GitHub Advisory Database record mirrored by OSV.
github.com - Monitored products — criticalVendor advisoryCVE-2026-55957
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Use
nvd.nist.gov - OpenSSF OSV / OSV ScannerPackage advisoryBIT-tomcat-2026-55957
Apache Tomcat: Authentication bypass with JNDIRealm and GSSAPI authenticated bind
osv.dev
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- GitHub Advisory DatabaseNov 5, 2026
- OpenSSF OSV / OSV ScannerNov 5, 2026
- CVE.orgNov 4, 2026
- Monitored products — criticalNov 3, 2026