Vulnerability · CVE-2026-56370
ImageMagick before 7.1.2-19 contains an out-of-bounds access vulnerability in ConnectedComponentsImage() when processing connected-components artifacts with invalid indices.
Published Jun 24, 2026 · catalog updated Oct 29, 2026 · ImageMagick before 7.1.2-19 contains
Last checked Oct 30, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-56370. EPSS is 0.18%. Act only if a listed version of ImageMagick before 7.1.2-19 contains is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (ImageMagick before 7.1.2-19 contains).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-107210 · Medium
- CVE-2026-107209 · High
- CVE-2026-107208 · Medium
- CVE-2026-106580 · High
- CVE-2026-106579 · High
- Severity
- Medium4.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.18%
- Remediation
- Version ranges on file
- Affected products
- cpe imagemagick/imagemagick
ImageMagick before 7.1.2-19 contains an out-of-bounds access vulnerability in ConnectedComponentsImage() when processing connected-components artifacts with invalid indices. Attackers can trigger access violations by specifying malformed connected-components definitions via CLI, causing denial of service or potential code execution.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe imagemagick/imagemagick< 6.9.13-44
- cpe imagemagick/imagemagick< 7.1.2-19
How to fix CVE-2026-56370
Upgrade
CVE-2026-56370 lists a fix boundary at 6.9.13-44. Compare the installed build with that boundary before you change production.
Version check
Affected < 6.9.13-44
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-56370. EPSS is 0.18%. Act only if a listed version of ImageMagick before 7.1.2-19 contains is installed.
Which versions are affected?
Compare what you have installed with < 6.9.13-44, < 7.1.2-19. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-125: Out-of-bounds Read. EPSS 0.18%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jun 24, 2026 · NIST NVD
Detected
ImageMagick before 7.1.2-19 contains an out-of-bounds access vulnerability in ConnectedComponentsImage() when processing connected-components artifacts with invalid indices. Attackers can trigger access violations by specifying malformed connected-components definitions via CLI, causing denial of service or potential code execution.
Oct 29, 2026 · NIST NVD
Updated
ImageMagick before 7.1.2-19 contains an out-of-bounds access vulnerability in ConnectedComponentsImage() when processing connected-components artifacts with invalid indices. Attackers can trigger access violations by specifying malformed connected-components definitions via CLI, causing denial of service or potential code execution.
Sources
- CVE.orgVulnerability recordCVE-2026-56370
Official CVE identifier
cve.org - NIST NVDVulnerability recordCVE-2026-56370
ImageMagick before 7.1.2-19 contains an out-of-bounds access vulnerability in ConnectedComponentsImage() when processing connected-components artifacts with invalid indices. Attackers can trigger access violations by specifying malformed connected-components definitions via CLI,
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 30, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 30, 2026
- NIST NVDOct 30, 2026