Vulnerabilities

Vulnerability · CVE-2026-56378

ImageMagick before 7.1.2-15 (and 6.x before 6.9.13-40) contains a heap out-of-bounds read in the PCD coder's DecodeImage loop.

Published Jun 21, 2026 · catalog updated Oct 29, 2026 · ImageMagick before 7.1.2-15 (and

Last checked Oct 30, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-56378. EPSS is 0.39%. Act only if a listed version of ImageMagick before 7.1.2-15 (and is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (ImageMagick before 7.1.2-15 (and).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium6.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.39%
Remediation
Version ranges on file
Affected products
cpe imagemagick/imagemagick

ImageMagick before 7.1.2-15 (and 6.x before 6.9.13-40) contains a heap out-of-bounds read in the PCD coder's DecodeImage loop. A crafted PCD file can trigger a one-byte heap out-of-bounds read during image decoding, resulting in denial of service and potential disclosure of an adjacent heap byte.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe imagemagick/imagemagick< 6.9.13-40
  • cpe imagemagick/imagemagick< 7.1.2-15

How to fix CVE-2026-56378

  • Upgrade

    CVE-2026-56378 lists a fix boundary at 6.9.13-40. Compare the installed build with that boundary before you change production.

  • Version check

    Affected < 6.9.13-40

  • Advisory

    Open the cve_org record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-56378. EPSS is 0.39%. Act only if a listed version of ImageMagick before 7.1.2-15 (and is installed.

Which versions are affected?

Compare what you have installed with < 6.9.13-40, < 7.1.2-15. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-125: Out-of-bounds Read. EPSS 0.39%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Jun 21, 2026 · NIST NVD

    Detected

    ImageMagick before 7.1.2-15 (and 6.x before 6.9.13-40) contains a heap out-of-bounds read in the PCD coder's DecodeImage loop. A crafted PCD file can trigger a one-byte heap out-of-bounds read during image decoding, resulting in denial of service and potential disclosure of an adjacent heap byte.

  2. Oct 29, 2026 · NIST NVD

    Updated

    ImageMagick before 7.1.2-15 (and 6.x before 6.9.13-40) contains a heap out-of-bounds read in the PCD coder's DecodeImage loop. A crafted PCD file can trigger a one-byte heap out-of-bounds read during image decoding, resulting in denial of service and potential disclosure of an adjacent heap byte.

Sources

  • CVE.orgVulnerability recordCVE-2026-56378

    Official CVE identifier

    cve.org
  • NIST NVDVulnerability recordCVE-2026-56378

    ImageMagick before 7.1.2-15 (and 6.x before 6.9.13-40) contains a heap out-of-bounds read in the PCD coder's DecodeImage loop. A crafted PCD file can trigger a one-byte heap out-of-bounds read during image decoding, resulting in denial of service and potential disclosure of an ad

    nvd.nist.gov

References

Freshness

Last verified in this catalog Oct 30, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgOct 30, 2026
  • NIST NVDOct 30, 2026