Vulnerabilities

Vulnerability · CVE-2026-56711

VLC media player versions 3.0.0 through 3.0.23 contain a memory-safety vulnerability reachable when processing crafted media.

Published Sep 9, 2026 · catalog updated Oct 29, 2026 · VLC media player versions

Last checked Oct 29, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-56711. EPSS is 0.12%. Act only if a listed version of VLC media player versions is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (VLC media player versions).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
Unknown—
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.12%
Remediation
Advisory link
Affected products
Debian:12 vlc · Debian:13 vlc · Debian:14 vlc

VLC media player versions 3.0.0 through 3.0.23 contain a memory-safety vulnerability reachable when processing crafted media. Exploitation requires user interaction and may result in application termination or code execution with the privileges of the VLC process.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • Debian:12 vlc0 → 3.0.24-0+deb12u1
  • Debian:13 vlc0 → 3.0.24-0+deb13u1
  • Debian:14 vlc0 → 3.0.24-1

How to fix CVE-2026-56711

  • Upgrade

    CVE-2026-56711 lists a fix boundary at 3.0.24-0+deb12u1. Compare the installed build with that boundary before you change production.

  • Version check

    Fixed in 3.0.24-0+deb12u1 · 2 other ranges on the advisory

  • Advisory

    Open the cve_org record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-56711. EPSS is 0.12%. Act only if a listed version of VLC media player versions is installed.

Which versions are affected?

Compare what you have installed with 0 → 3.0.24-0+deb12u1, 0 → 3.0.24-0+deb13u1, 0 → 3.0.24-1. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.12%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Sep 9, 2026 · Trivy Vulnerability DB

    Detected

    VLC media player versions 3.0.0 through 3.0.23 contain a memory-safety vulnerability reachable when processing crafted media. Exploitation requires user interaction and may result in application termination or code execution with the privileges of the VLC process.

  2. Oct 29, 2026 · Trivy Vulnerability DB

    Fix available

    vlc fixed in 3.0.24-0+deb12u1; vlc fixed in 3.0.24-0+deb13u1; vlc fixed in 3.0.24-1

  3. Oct 29, 2026 · Trivy Vulnerability DB

    Fix available

    vlc fixed in 3.0.24-0+deb12u1

  4. Oct 29, 2026 · Trivy Vulnerability DB

    Fix available

    vlc fixed in 3.0.24-0+deb13u1

  5. Oct 29, 2026 · Trivy Vulnerability DB

    Fix available

    vlc fixed in 3.0.24-1

  6. Oct 29, 2026 · Trivy Vulnerability DB

    Updated

    VLC media player versions 3.0.0 through 3.0.23 contain a memory-safety vulnerability reachable when processing crafted media. Exploitation requires user interaction and may result in application termination or code execution with the privileges of the VLC process.

Sources

  • CVE.orgVulnerability recordCVE-2026-56711

    Official CVE identifier

    cve.org
  • Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-56711

    VLC media player versions 3.0.0 through 3.0.23 contain a memory-safety vulnerability reachable when processing crafted media. Exploitation requires user interaction and may result in application termination or code execution with the privileges of the VLC process.

    osv.dev

References

Freshness

Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgOct 29, 2026
  • Trivy Vulnerability DBOct 29, 2026