Vulnerabilities

Security fix · CVE-2026-57188

Asterisk is an open source private branch exchange and telephony toolkit.

Published Oct 27, 2026 · catalog updated Oct 28, 2026 · Asterisk is an open

Last checked Nov 6, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-57188. EPSS is 0.52%. Act only if a listed version of Asterisk is an open is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Asterisk is an open).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High7.1
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.52%
Remediation
Advisory link
Affected products
Debian:14 asterisk · vendor asterisk asterisk · vendor asterisk certified-asterisk

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may cause a stack buffer overflow in handling using carefully crafted packets. The module must be loaded, an XMPP connection must be configured in , and the attacker must have an XMPP account on the same or a federated server. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • Debian:14 asterisk0 → 1:22.10.1+dfsg+~cs6.17.60671434-1
  • vendor asterisk asteriskversion unspecified
  • vendor asterisk certified-asteriskversion unspecified

How to fix CVE-2026-57188

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-57188. EPSS is 0.52%. Act only if a listed version of Asterisk is an open is installed.

Which versions are affected?

Compare what you have installed with 0 → 1:22.10.1+dfsg+~cs6.17.60671434-1. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-787: Out-of-bounds Write. EPSS 0.52%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 27, 2026 · Trivy Vulnerability DB

    Detected

    Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may cause a stack buffer overflow in handling using carefully crafted packets. The module must be loaded, an XMPP connection must be configured in , and the attacker must have an XMPP account on the s

  2. Oct 28, 2026 · Trivy Vulnerability DB

    Fix available

    asterisk fixed in 1:22.10.1+dfsg+~cs6.17.60671434-1

  3. Oct 28, 2026 · Trivy Vulnerability DB

    Fix available

    asterisk fixed in 1:22.10.1+dfsg+~cs6.17.60671434-1

  4. Oct 28, 2026 · Trivy Vulnerability DB

    Updated

    Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may cause a stack buffer overflow in handling using carefully crafted packets. The module must be loaded, an XMPP connection must be configured in , and the attacker must have an XMPP account on the s

Sources

  • CVE.orgVulnerability recordCVE-2026-57188

    Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may cause a stack buffer overflow in handling using carefully crafted packets. T

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2026-57188

    30-day exploitation probability 0.52%

    first.org
  • Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-57188

    Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may cause a stack buffer overflow in handling using carefully crafted packets. T

    osv.dev

References

Freshness

Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 31, 2026
  • CVE.orgOct 28, 2026
  • Trivy Vulnerability DBOct 28, 2026