Vulnerabilities

Security fix · CVE-2026-57221

RabbitMQ is a messaging and streaming broker.

Published Jul 10, 2026 · catalog updated Oct 26, 2026 · RabbitMQ is a messaging

Last checked Oct 29, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-57221. EPSS is 0.41%. Act only if a listed version of RabbitMQ is a messaging is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (RabbitMQ is a messaging).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
Medium5.0
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.41%
Remediation
Advisory link
Affected products
Debian:12 rabbitmq-server · Debian:13 rabbitmq-server · Debian:14 rabbitmq-server

RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6, RabbitMQ does not perform authorization checks on passive queue.declare and exchange.declare AMQP 0-9-1 operations, allowing any authenticated user who can connect to a virtual host to enumerate queue and exchange names and read queue message and consumer counts. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • Debian:12 rabbitmq-server3.10.8-1.1, 3.10.8-1.1+deb12u1, 3.10.8-2
  • Debian:13 rabbitmq-server4.0.5-10, 4.0.5-11, 4.0.5-12
  • Debian:14 rabbitmq-server0 → 4.3.0-2

How to fix CVE-2026-57221

  • Upgrade

    CVE-2026-57221 lists a fix boundary at 4.3.0-2. Compare the installed build with that boundary before you change production.

  • Version check

    Fixed in 4.3.0-2 · 6 other ranges on the advisory

  • Advisory

    Open the cve_org record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-57221. EPSS is 0.41%. Act only if a listed version of RabbitMQ is a messaging is installed.

Which versions are affected?

Compare what you have installed with 3.10.8-1.1, 3.10.8-1.1+deb12u1, 3.10.8-2, 4.0.5-10, 4.0.5-11, 4.0.5-12, 0 → 4.3.0-2. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.41%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Jul 10, 2026 · Trivy Vulnerability DB

    Detected

    RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6, RabbitMQ does not perform authorization checks on passive queue.declare and exchange.declare AMQP 0-9-1 operations, allowing any authenticated user who can connect to a virtual host to enumerate queue and exchange names and read queue message and consumer counts. This issue is fixed in versions 3.13.15, 4.0.

  2. Oct 26, 2026 · Trivy Vulnerability DB

    Fix available

    rabbitmq-server fixed in 4.3.0-2

  3. Oct 26, 2026 · Trivy Vulnerability DB

    Fix available

    rabbitmq-server fixed in 4.3.0-2

  4. Oct 26, 2026 · Trivy Vulnerability DB

    Updated

    RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6, RabbitMQ does not perform authorization checks on passive queue.declare and exchange.declare AMQP 0-9-1 operations, allowing any authenticated user who can connect to a virtual host to enumerate queue and exchange names and read queue message and consumer counts. This issue is fixed in versions 3.13.15, 4.0.

Sources

  • CVE.orgVulnerability recordCVE-2026-57221

    Official CVE identifier

    cve.org
  • Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-57221

    RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6, RabbitMQ does not perform authorization checks on passive queue.declare and exchange.declare AMQP 0-9-1 operations, allowing any authenticated user who can connect to a virtual host to enum

    osv.dev

References

Freshness

Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgOct 26, 2026
  • Trivy Vulnerability DBOct 26, 2026