Vulnerability · CVE-2026-58032
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki.
Published Jul 1, 2026 · catalog updated Oct 26, 2026 · Improper Neutralization of Input
Last checked Oct 29, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-58032. EPSS is 0.30%. Act only if a listed version of Improper Neutralization of Input is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Improper Neutralization of Input).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium6.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.30%
- Remediation
- Advisory link
- Affected products
- Debian:12 mediawiki · Debian:13 mediawiki · Debian:14 mediawiki
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files resources/src/mediawiki.Api/index.Js. This issue affects MediaWiki: from * before 1.46.0, 1.45.4, 1.44.6, 1.43.9.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:12 mediawiki1:1.39.10-1, 1:1.39.10-1~deb12u1, 1:1.39.12-1~deb12u1
- Debian:13 mediawiki0 → 1:1.43.9+dfsg-1~deb13u1
- Debian:14 mediawiki0 → 1:1.43.9+dfsg-1
How to fix CVE-2026-58032
Upgrade
CVE-2026-58032 lists a fix boundary at 1:1.43.9+dfsg-1~deb13u1. Compare the installed build with that boundary before you change production.
Version check
Fixed in 1:1.43.9+dfsg-1~deb13u1 · 4 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-58032. EPSS is 0.30%. Act only if a listed version of Improper Neutralization of Input is installed.
Which versions are affected?
Compare what you have installed with 1:1.39.10-1, 1:1.39.10-1~deb12u1, 1:1.39.12-1~deb12u1, 0 → 1:1.43.9+dfsg-1~deb13u1, 0 → 1:1.43.9+dfsg-1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.30%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jul 1, 2026 · Trivy Vulnerability DB
Detected
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files resources/src/mediawiki.Api/index.Js. This issue affects MediaWiki: from * before 1.46.0, 1.45.4, 1.44.6, 1.43.9.
Oct 26, 2026 · Trivy Vulnerability DB
Fix available
mediawiki fixed in 1:1.43.9+dfsg-1~deb13u1; mediawiki fixed in 1:1.43.9+dfsg-1
Oct 26, 2026 · Trivy Vulnerability DB
Fix available
mediawiki fixed in 1:1.43.9+dfsg-1~deb13u1
Oct 26, 2026 · Trivy Vulnerability DB
Fix available
mediawiki fixed in 1:1.43.9+dfsg-1
Oct 26, 2026 · Trivy Vulnerability DB
Updated
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files resources/src/mediawiki.Api/index.Js. This issue affects MediaWiki: from * before 1.46.0, 1.45.4, 1.44.6, 1.43.9.
Sources
- CVE.orgVulnerability recordCVE-2026-58032
Official CVE identifier
cve.org - Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-58032
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files resources/src/mediawiki.Api/index.Js. This issue affects MediaWiki: from * before 1.46.
osv.dev
References
Freshness
Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 26, 2026
- Trivy Vulnerability DBOct 26, 2026