Vulnerability · CVE-2026-59190
Grav Admin Plugin — IDOR Privilege Escalation via saveUser()
Published Jul 10, 2026 · catalog updated Jul 10, 2026 · Grav Admin Plugin —
Last checked Oct 29, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-59190. EPSS is 0.27%. Act only if a listed version of Grav Admin Plugin — is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Grav Admin Plugin —).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-61454 · High
- CVE-2026-59193 · Medium
- CVE-2026-61456 · Medium
- CVE-2026-61455 · High
- CVE-2026-61450 · High
- Severity
- High8.7
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.27%
- Remediation
- Version ranges on file
- Affected products
- stated named in the record · vendor getgrav grav
grav-plugin-admin is an HTML user interface that provides a way to configure Grav and create and modify pages. In 1.10.52 and earlier, an authenticated attacker with admin.users permission can change the password of any user account, including the super administrator, by sending a direct POST request to /admin/user/{username}?task=save with data[password] because saveUser authorizes the caller's user-management permission but does not verify whether the caller may edit the target user. This issue is expected to be fixed in version 1.10.53.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- stated named in the record<= 1.10.52
- vendor getgrav gravversion unspecified
How to fix CVE-2026-59190
Upgrade
CVE-2026-59190 lists a fix boundary at 1.10.52. Compare the installed build with that boundary before you change production.
Version check
Affected <= 1.10.52
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-59190. EPSS is 0.27%. Act only if a listed version of Grav Admin Plugin — is installed.
Which versions are affected?
Compare what you have installed with named in the record <= 1.10.52. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-639: Authorization Bypass Through User-Controlled Key. EPSS 0.27%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jul 10, 2026 · CVE.org
Updated
grav-plugin-admin is an HTML user interface that provides a way to configure Grav and create and modify pages. In 1.10.52 and earlier, an authenticated attacker with admin.users permission can change the password of any user account, including the super administrator, by sending a direct POST request to /admin/user/{username}?task=save with data[password] because saveUser authorizes the caller's u
Oct 25, 2026 · Tenable CVE Database
Detected
grav-plugin-admin is an HTML user interface that provides a way to configure Grav and create and modify pages. In 1.10.52 and earlier, an authenticated attacker with admin.users permission can change the password of any user account, including the super administrator, by sending a direct POST request to /admin/user/{username}?task=save with data[password] because saveUser authorizes the caller's u
Sources
- CVE.orgVulnerability recordCVE-2026-59190
grav-plugin-admin is an HTML user interface that provides a way to configure Grav and create and modify pages. In 1.10.52 and earlier, an authenticated attacker with admin.users permission can change the password of any user account, including the super administrator, by sending
cve.org - FIRST EPSSExploitation probabilityCVE-2026-59190
30-day exploitation probability 0.27%
first.org - Tenable CVE DatabaseVulnerability recordCVE-2026-59190
grav-plugin-admin is an HTML user interface that provides a way to configure Grav and create and modify pages. In 1.10.52 and earlier, an authenticated attacker with admin.users permission can change the password of any user account, including the super administrator, by sending a direct POST request to /admin/user/{username}?task=save with data[password] because saveUser authorizes the caller's u
tenable.com
References
Freshness
Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 29, 2026
- CVE.orgOct 26, 2026
- Tenable CVE DatabaseOct 26, 2026