Vulnerability · CVE-2026-59199
Pillow: Heap out-of-bounds write / via signed coordinate overflow
Published Jul 14, 2026 · catalog updated Jul 15, 2026 · Pillow
Last checked Nov 7, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-59199. EPSS is 0.39%. Act only if a listed version of Pillow is installed.
Gaps on this record
- No version range is stored. A customer cannot check an installed version against this record.
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-54058 · High
- CVE-2026-55379 · High
- CVE-2026-54060 · High
- CVE-2026-54059 · High
- CVE-2026-25990 · High
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.39%
- Remediation
- Advisory link
- Affected products
- vendor python-pillow Pillow
Pillow is a Python imaging library. Prior to 12.3.0, Pillow public image coordinate APIs can trigger a native heap out-of-bounds write when given coordinates near the signed 32-bit integer limits in Image.paste(), Image.crop(), or Image.alpha_composite(). This issue is fixed in version 12.3.0.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor python-pillow Pillowversion unspecified
How to fix CVE-2026-59199
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
No version range is stored, so an installed version cannot be checked on this page.
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-59199. EPSS is 0.39%. Act only if a listed version of Pillow is installed.
Which versions are affected?
Affected version ranges are not on this record. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-190: Integer Overflow; CWE-787: Out-of-bounds Write. EPSS 0.39%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jul 15, 2026 · CVE.org
Updated
Pillow is a Python imaging library. Prior to 12.3.0, Pillow public image coordinate APIs can trigger a native heap out-of-bounds write when given coordinates near the signed 32-bit integer limits in Image.paste(), Image.crop(), or Image.alpha_composite(). This issue is fixed in version 12.3.0.
Nov 4, 2026 · Ubuntu Security Notices
Detected
CVE-2026-59199 is listed by USN-8999-1: Pillow vulnerabilities.
Sources
- CVE.orgVulnerability recordCVE-2026-59199
Pillow is a Python imaging library. Prior to 12.3.0, Pillow public image coordinate APIs can trigger a native heap out-of-bounds write when given coordinates near the signed 32-bit integer limits in Image.paste(), Image.crop(), or Image.alpha_composite(). This issue is fixed in v
cve.org - Ubuntu Security NoticesVendor advisoryCVE-2026-59199
It was discovered that Pillow incorrectly handled map stride values when loading certain McIdas AREA images. An attacker could possibly use this issue to obtain sensitive information or cause a denial of service. (CVE-2026-54058) It was discovered that Pillow did not properly che
ubuntu.com
References
- https://github.com/python-pillow/Pillow/commit/ceefc348eb3c3844c7f9796ef2cc3a7dd · github.com
- https://github.com/python-pillow/Pillow/pull/9703 · github.com
- https://github.com/python-pillow/Pillow/releases/tag/12.3.0 · github.com
- https://github.com/python-pillow/Pillow/security/advisories/GHSA-6r8x-57c9-28j4 · github.com
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Ubuntu Security NoticesNov 7, 2026
- CVE.orgNov 4, 2026