Vulnerability · CVE-2026-59242
Apache Airflow's XCom endpoint passed a string-literal payload through without the guard, allowing an authenticated API user with XCom write-and-read access to instant…
Published Aug 12, 2026 · catalog updated Oct 24, 2026 · the affected product
Last checked Nov 2, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-59242. EPSS is 0.53%. Act only if a listed version of the affected product is installed.
Gaps on this record
- No plain product name is stored. The page cannot tell you which product to check.
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-82355 · Medium
- CVE-2026-75158 · Medium
- CVE-2026-86473 · Critical
- CVE-2026-68971 · Medium
- CVE-2026-68970 · Medium
- Severity
- Medium5.4
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.53%
- Remediation
- Version ranges on file
- Affected products
- cpe apache/airflow
Apache Airflow's XCom endpoint passed a string-literal payload through without the guard, allowing an authenticated API user with XCom write-and-read access to instantiate arbitrary classes on the API server (CWE-502). An authenticated user who can write an XCom value and then read it back with triggers the unsafe instantiation. Users are advised to upgrade to apache-airflow 3.3.1 or later, which rejects reserved XCom serialization keys submitted as JSON string literals.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apache/airflow< 3.3.1
How to fix CVE-2026-59242
Upgrade
CVE-2026-59242 lists a fix boundary at 3.3.1. Compare the installed build with that boundary before you change production.
Version check
Affected < 3.3.1
Advisory
Open the inventory_high record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-59242. EPSS is 0.53%. Act only if a listed version of the affected product is installed.
Which versions are affected?
Compare what you have installed with < 3.3.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-502: Deserialization of Untrusted Data. EPSS 0.53%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Aug 12, 2026 · Monitored products — high
Detected
Apache Airflow's XCom endpoint passed a string-literal payload through without the guard, allowing an authenticated API user with XCom write-and-read access to instantiate arbitrary classes on the API server (CWE-502). An authenticated user who can write an XCom value and then read it back with triggers the unsafe instantiation. Users are advised to upgrade to apache-airflow 3.3.1 or later, which
Oct 24, 2026 · Monitored products — high
Updated
Apache Airflow's XCom endpoint passed a string-literal payload through without the guard, allowing an authenticated API user with XCom write-and-read access to instantiate arbitrary classes on the API server (CWE-502). An authenticated user who can write an XCom value and then read it back with triggers the unsafe instantiation. Users are advised to upgrade to apache-airflow 3.3.1 or later, which
Sources
- Monitored products — highVendor advisoryCVE-2026-59242
Apache Airflow's XCom endpoint passed a string-literal payload through without the guard, allowing an authenticated API user with XCom write-and-read access to instantiate arbitrary classes on the API server (CWE-502). An authenticated user who can write an XCom value and then read it back with triggers the unsafe instantiation. Users are advised to upgrade to apache-airflow 3.3.1 or later, which
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Monitored products — highNov 2, 2026