Vulnerability · CVE-2026-59998
sshd in OpenSSH before 10.4 has an undocumented security-relevant behavior: GSSAPIStrictAcceptorCheck has no value if the server is in Windows Active Directory.
Published Jul 8, 2026 · catalog updated Oct 23, 2026 · sshd in OpenSSH before
Last checked Oct 29, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-59998. EPSS is 0.18%. Act only if a listed version of sshd in OpenSSH before is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (sshd in OpenSSH before).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium4.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.18%
- Remediation
- Advisory link
- Affected products
- Ubuntu:18.04:LTS openssh-ssh1 · Ubuntu:20.04:LTS openssh-ssh1 · Ubuntu:Pro:14.04:LTS openssh · Ubuntu:Pro:16.04:LTS openssh · Ubuntu:Pro:18.04:LTS openssh · Ubuntu:Pro:20.04:LTS openssh
sshd in OpenSSH before 10.4 has an undocumented security-relevant behavior: GSSAPIStrictAcceptorCheck has no value if the server is in Windows Active Directory.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Ubuntu:18.04:LTS openssh-ssh11:7.5p1-8, 1:7.5p1-9, 1:7.5p1-9build1
- Ubuntu:20.04:LTS openssh-ssh11:7.5p1-11build1
- Ubuntu:Pro:14.04:LTS openssh0 → 1:6.6p1-2ubuntu2.13+esm4
- Ubuntu:Pro:16.04:LTS openssh0 → 1:7.2p2-4ubuntu2.10+esm10
- Ubuntu:Pro:18.04:LTS openssh0 → 1:7.6p1-4ubuntu0.7+esm6
- Ubuntu:Pro:20.04:LTS openssh0 → 1:8.2p1-4ubuntu0.13+esm3
- Ubuntu:Pro:FIPS-updates:16.04:LTS openssh1:7.2p2-4ubuntu2.fips.2.2.3, 1:7.2p2-4ubuntu2.fips.2.4.1, 1:7.2p2-4ubuntu2.fips.2.4.2
- Ubuntu:Pro:FIPS-updates:18.04:LTS openssh1:7.9p1-10~ubuntu18.04.fips.0.1, 1:7.9p1-10~ubuntu18.04.fips.0.2, 1:7.9p1-10~ubuntu18.04.fips.0.3
- Ubuntu:Pro:FIPS-updates:20.04:LTS openssh1:8.2p1-4ubuntu0.fips.0.2.1, 1:8.2p1-4ubuntu0.fips.0.4.0, 1:8.2p1-4ubuntu0.fips.0.5.0
- Ubuntu:Pro:FIPS:16.04:LTS openssh1:7.2p2-4ubuntu2.fips.2.2, 1:7.2p2-4ubuntu2.fips.2.2.1, 1:7.2p2-4ubuntu2.fips.2.10.1
- Ubuntu:Pro:FIPS:18.04:LTS openssh1:7.9p1-10~ubuntu18.04.fips.0.1, 1:7.9p1-10~ubuntu18.04.fips.0.2
- Ubuntu:Pro:FIPS:20.04:LTS openssh1:8.2p1-4ubuntu0.fips.0.2.1
How to fix CVE-2026-59998
Upgrade
CVE-2026-59998 lists a fix boundary at 1:6.6p1-2ubuntu2.13+esm4. Compare the installed build with that boundary before you change production.
Version check
Fixed in 1:6.6p1-2ubuntu2.13+esm4 · 7 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-59998. EPSS is 0.18%. Act only if a listed version of sshd in OpenSSH before is installed.
Which versions are affected?
Compare what you have installed with 1:7.5p1-8, 1:7.5p1-9, 1:7.5p1-9build1, 1:7.5p1-11build1, 0 → 1:6.6p1-2ubuntu2.13+esm4, 0 → 1:7.2p2-4ubuntu2.10+esm10, 0 → 1:7.6p1-4ubuntu0.7+esm6, 0 → 1:8.2p1-4ubuntu0.13+esm3. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.18%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jul 8, 2026 · OpenSSF OSV / OSV Scanner
Detected
sshd in OpenSSH before 10.4 has an undocumented security-relevant behavior: GSSAPIStrictAcceptorCheck has no value if the server is in Windows Active Directory.
Oct 23, 2026 · OpenSSF OSV / OSV Scanner
Fix available
openssh fixed in 1:6.6p1-2ubuntu2.13+esm4; openssh fixed in 1:7.2p2-4ubuntu2.10+esm10; openssh fixed in 1:7.6p1-4ubuntu0.7+esm6; openssh fixed in 1:8.2p1-4ubuntu0.13+esm3
Oct 23, 2026 · OpenSSF OSV / OSV Scanner
Fix available
openssh fixed in 1:6.6p1-2ubuntu2.13+esm4
Oct 23, 2026 · OpenSSF OSV / OSV Scanner
Fix available
openssh fixed in 1:7.2p2-4ubuntu2.10+esm10
Oct 23, 2026 · OpenSSF OSV / OSV Scanner
Fix available
openssh fixed in 1:7.6p1-4ubuntu0.7+esm6
Oct 23, 2026 · OpenSSF OSV / OSV Scanner
Fix available
openssh fixed in 1:8.2p1-4ubuntu0.13+esm3
Oct 23, 2026 · OpenSSF OSV / OSV Scanner
Updated
sshd in OpenSSH before 10.4 has an undocumented security-relevant behavior: GSSAPIStrictAcceptorCheck has no value if the server is in Windows Active Directory.
Sources
- CVE.orgVulnerability recordCVE-2026-59998
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-59998
30-day exploitation probability 0.18%
first.org - OpenSSF OSV / OSV ScannerPackage advisoryUBUNTU-CVE-2026-59998osv.dev
References
Freshness
Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 29, 2026
- CVE.orgOct 23, 2026
- OpenSSF OSV / OSV ScannerOct 23, 2026