Vulnerabilities

Vulnerability · CVE-2026-61431

PraisonAI before 4.6.78 contains a path traversal vulnerability in ContextGatherer that fails to validate include paths in .praisoncontext and .praisoninclude files.

Published Jul 10, 2026 · catalog updated Oct 24, 2026 · PraisonAI before 4.6.78 contains

Last checked Oct 25, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-61431. EPSS is 0.37%. Act only if a listed version of PraisonAI before 4.6.78 contains is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (PraisonAI before 4.6.78 contains).
  • No version range is stored. A customer cannot check an installed version against this record.
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
Medium6.8
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.37%
Remediation
Advisory link
Affected products
See sources for product scope

PraisonAI before 4.6.78 contains a path traversal vulnerability in ContextGatherer that fails to validate include paths in .praisoncontext and .praisoninclude files. Attackers can supply absolute paths or parent directory traversal sequences to read arbitrary files outside the workspace and include their contents in the generated context bundle.

No affected version ranges are stored yet. Use the vendor advisory before you decide this record does not apply.

How to fix CVE-2026-61431

  • No stored fix

    No vendor fix text is stored. Use the linked advisory before you change production.

  • Version check

    No version range is stored, so an installed version cannot be checked on this page.

  • Advisory

    Open the cve_org record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-61431. EPSS is 0.37%. Act only if a listed version of PraisonAI before 4.6.78 contains is installed.

Which versions are affected?

Affected version ranges are not on this record. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-22: Path Traversal. EPSS 0.37%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Jul 10, 2026 · NIST NVD

    Detected

    PraisonAI before 4.6.78 contains a path traversal vulnerability in ContextGatherer that fails to validate include paths in .praisoncontext and .praisoninclude files. Attackers can supply absolute paths or parent directory traversal sequences to read arbitrary files outside the workspace and include their contents in the generated context bundle.

  2. Oct 24, 2026 · NIST NVD

    Updated

    PraisonAI before 4.6.78 contains a path traversal vulnerability in ContextGatherer that fails to validate include paths in .praisoncontext and .praisoninclude files. Attackers can supply absolute paths or parent directory traversal sequences to read arbitrary files outside the workspace and include their contents in the generated context bundle.

Sources

  • CVE.orgVulnerability recordCVE-2026-61431

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2026-61431

    30-day exploitation probability 0.37%

    first.org
  • NIST NVDVulnerability recordCVE-2026-61431

    PraisonAI before 4.6.78 contains a path traversal vulnerability in ContextGatherer that fails to validate include paths in .praisoncontext and .praisoninclude files. Attackers can supply absolute paths or parent directory traversal sequences to read arbitrary files outside the wo

    nvd.nist.gov

References

Freshness

Last verified in this catalog Oct 25, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 25, 2026
  • CVE.orgOct 25, 2026
  • NIST NVDOct 25, 2026